You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
86 lines
2.2 KiB
86 lines
2.2 KiB
# Generated by rust2rpm 25
|
|
%bcond_without check
|
|
|
|
%global crate procs
|
|
|
|
Name: rust-procs
|
|
Version: 0.14.4
|
|
Release: %autorelease
|
|
Summary: Modern replacement for ps
|
|
|
|
License: MIT
|
|
URL: https://crates.io/crates/procs
|
|
Source: %{crates_source}
|
|
# Automatically generated patch to strip dependencies and normalize metadata
|
|
Patch: procs-fix-metadata-auto.diff
|
|
# Manually created patch for downstream crate metadata changes
|
|
# * remove docker feature / dockworker dependency
|
|
Patch: procs-fix-metadata.diff
|
|
|
|
BuildRequires: cargo-rpm-macros >= 24
|
|
|
|
%global _description %{expand:
|
|
A modern replacement for ps.}
|
|
|
|
%description %{_description}
|
|
|
|
%package -n %{crate}
|
|
Summary: %{summary}
|
|
# (MIT OR Apache-2.0) AND Unicode-DFS-2016
|
|
# 0BSD OR MIT OR Apache-2.0
|
|
# Apache-2.0
|
|
# Apache-2.0 OR MIT
|
|
# Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT
|
|
# BSD-3-Clause
|
|
# MIT
|
|
# MIT OR Apache-2.0
|
|
# MIT OR Zlib OR Apache-2.0
|
|
# MPL-2.0
|
|
# Unlicense OR MIT
|
|
License: Apache-2.0 AND BSD-3-Clause AND MIT AND MPL-2.0 AND Unicode-DFS-2016 AND (0BSD OR MIT OR Apache-2.0) AND (Apache-2.0 OR MIT) AND (Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT) AND (MIT OR Zlib OR Apache-2.0) AND (Unlicense OR MIT)
|
|
# LICENSE.dependencies contains a full license breakdown
|
|
|
|
%description -n %{crate} %{_description}
|
|
|
|
%files -n %{crate}
|
|
%license LICENSE
|
|
%license LICENSE.dependencies
|
|
%doc CHANGELOG.md
|
|
%doc README.md
|
|
%{_bindir}/procs
|
|
%{bash_completions_dir}/procs.bash
|
|
%{fish_completions_dir}/procs.fish
|
|
%{zsh_completions_dir}/_procs
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version} -p1
|
|
%cargo_prep
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires
|
|
|
|
%build
|
|
%cargo_build
|
|
%{cargo_license_summary}
|
|
%{cargo_license} > LICENSE.dependencies
|
|
|
|
%install
|
|
%cargo_install
|
|
|
|
# generate and install shell completions
|
|
target/rpm/procs --gen-completion-out bash > procs.bash
|
|
target/rpm/procs --gen-completion-out fish > procs.fish
|
|
target/rpm/procs --gen-completion-out zsh > _procs
|
|
|
|
install -Dpm 0644 procs.bash -t %{buildroot}/%{bash_completions_dir}
|
|
install -Dpm 0644 procs.fish -t %{buildroot}/%{fish_completions_dir}
|
|
install -Dpm 0644 _procs -t %{buildroot}/%{zsh_completions_dir}
|
|
|
|
%if %{with check}
|
|
%check
|
|
%cargo_test
|
|
%endif
|
|
|
|
%changelog
|
|
%autochangelog
|