You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
135 lines
3.8 KiB
135 lines
3.8 KiB
# Generated by rust2rpm 10
|
|
%bcond_with check
|
|
%global debug_package %{nil}
|
|
|
|
%global crate proc-macro2
|
|
|
|
Name: rust-%{crate}-0.4
|
|
Version: 0.4.30
|
|
Release: 7%{?dist}
|
|
Summary: Stable implementation of the upcoming new `proc_macro` API
|
|
|
|
# Upstream license specification: MIT/Apache-2.0
|
|
License: MIT or ASL 2.0
|
|
URL: https://crates.io/crates/proc-macro2
|
|
Source: %{crates_source}
|
|
|
|
ExclusiveArch: %{rust_arches}
|
|
%if %{__cargo_skip_build}
|
|
BuildArch: noarch
|
|
%endif
|
|
|
|
BuildRequires: rust-packaging
|
|
|
|
%global _description %{expand:
|
|
Stable implementation of the upcoming new `proc_macro` API. Comes with an
|
|
option, off by default, to also reimplement itself in terms of the upstream
|
|
unstable API.}
|
|
|
|
%description %{_description}
|
|
|
|
%package devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description devel %{_description}
|
|
|
|
This package contains library source intended for building other packages
|
|
which use "%{crate}" crate.
|
|
|
|
%files devel
|
|
%license LICENSE-MIT LICENSE-APACHE
|
|
%doc README.md
|
|
%{cargo_registry}/%{crate}-%{version}/
|
|
|
|
%package -n %{name}+default-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+default-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages
|
|
which use "default" feature of "%{crate}" crate.
|
|
|
|
%files -n %{name}+default-devel
|
|
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
|
|
|
|
%package -n %{name}+nightly-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+nightly-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages
|
|
which use "nightly" feature of "%{crate}" crate.
|
|
|
|
%files -n %{name}+nightly-devel
|
|
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
|
|
|
|
%package -n %{name}+proc-macro-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+proc-macro-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages
|
|
which use "proc-macro" feature of "%{crate}" crate.
|
|
|
|
%files -n %{name}+proc-macro-devel
|
|
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
|
|
|
|
%package -n %{name}+span-locations-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+span-locations-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages
|
|
which use "span-locations" feature of "%{crate}" crate.
|
|
|
|
%files -n %{name}+span-locations-devel
|
|
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
|
%cargo_prep
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires
|
|
|
|
%build
|
|
%cargo_build
|
|
|
|
%install
|
|
%cargo_install
|
|
|
|
%if %{with check}
|
|
%check
|
|
%cargo_test
|
|
%endif
|
|
|
|
%changelog
|
|
* Sun Nov 19 2023 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.4.30-7
|
|
- Rebuilt for MSVSphere 9.2
|
|
|
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.30-7
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
|
|
|
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.30-6
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
|
|
|
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.30-5
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
|
|
|
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.30-4
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
|
|
|
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.30-3
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
|
|
|
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.30-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
|
|
|
* Sun Aug 18 15:24:04 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.30-1
|
|
- Initial package
|