commit
ba922c1302
@ -0,0 +1 @@
|
||||
/print_bytes-0.6.0.crate
|
@ -0,0 +1,12 @@
|
||||
--- print_bytes-0.6.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ print_bytes-0.6.0/Cargo.toml 2022-07-03T17:21:10.069497+00:00
|
||||
@@ -58,9 +58,3 @@
|
||||
[features]
|
||||
specialization = []
|
||||
|
||||
-[target."cfg(windows)".dependencies.windows-sys]
|
||||
-version = "0.36"
|
||||
-features = [
|
||||
- "Win32_Foundation",
|
||||
- "Win32_System_Console",
|
||||
-]
|
@ -0,0 +1,87 @@
|
||||
# Generated by rust2rpm 21
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate print_bytes
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.6.0
|
||||
Release: %autorelease
|
||||
Summary: Print bytes as losslessly as possible
|
||||
|
||||
# Upstream license specification: MIT OR Apache-2.0
|
||||
License: MIT OR Apache-2.0
|
||||
URL: https://crates.io/crates/print_bytes
|
||||
Source: %{crates_source}
|
||||
# Initial patched metadata
|
||||
Patch0: print_bytes-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Print bytes as losslessly as possible.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/COPYRIGHT
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+specialization-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+specialization-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "specialization" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+specialization-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
Loading…
Reference in new issue