You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
122 lines
3.6 KiB
122 lines
3.6 KiB
## START: Set by rpmautospec
|
|
## (rpmautospec version 0.3.5)
|
|
## RPMAUTOSPEC: autorelease, autochangelog
|
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
|
release_number = 1;
|
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
|
print(release_number + base_release_number - 1);
|
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
|
## END: Set by rpmautospec
|
|
|
|
# Generated by rust2rpm 24
|
|
%bcond_without check
|
|
%global debug_package %{nil}
|
|
|
|
%global crate predicates-tree
|
|
|
|
Name: rust-predicates-tree
|
|
Version: 1.0.9
|
|
Release: %autorelease
|
|
Summary: Render boolean-valued predicate functions results as a tree
|
|
|
|
License: MIT OR Apache-2.0
|
|
URL: https://crates.io/crates/predicates-tree
|
|
Source: %{crates_source}
|
|
|
|
BuildRequires: rust-packaging >= 21
|
|
|
|
%global _description %{expand:
|
|
Render boolean-valued predicate functions results as a tree.}
|
|
|
|
%description %{_description}
|
|
|
|
%package devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "%{crate}" crate.
|
|
|
|
%files devel
|
|
%license %{crate_instdir}/LICENSE-APACHE
|
|
%license %{crate_instdir}/LICENSE-MIT
|
|
%doc %{crate_instdir}/README.md
|
|
%{crate_instdir}/
|
|
|
|
%package -n %{name}+default-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+default-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "default" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+default-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
|
%cargo_prep
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires
|
|
|
|
%build
|
|
%cargo_build
|
|
|
|
%install
|
|
%cargo_install
|
|
|
|
%if %{with check}
|
|
%check
|
|
%cargo_test
|
|
%endif
|
|
|
|
%changelog
|
|
* Fri Jan 12 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 1.0.9-1
|
|
- Rebuilt for MSVSphere 9.3
|
|
|
|
* Mon Apr 17 2023 Fabio Valentini <decathorpe@gmail.com> - 1.0.9-1
|
|
- Update to version 1.0.9; Fixes RHBZ#2178704
|
|
|
|
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.7-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
|
|
|
* Wed Dec 21 2022 Fabio Valentini <decathorpe@gmail.com> - 1.0.7-1
|
|
- Update to version 1.0.7; Fixes RHBZ#2011948
|
|
|
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.3-3
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
|
|
|
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.3-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
|
|
|
* Fri Aug 06 2021 Fabio Valentini <decathorpe@gmail.com> - 1.0.3-1
|
|
- Update to version 1.0.3; Fixes RHBZ#1990646
|
|
|
|
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.2-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
|
|
|
* Thu Mar 04 2021 Fabio Valentini <decathorpe@gmail.com> - 1.0.2-1
|
|
- Update to version 1.0.2.
|
|
|
|
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.1-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
|
|
|
* Tue Dec 29 2020 Fabio Valentini <decathorpe@gmail.com> - 1.0.1-1
|
|
- Update to version 1.0.1.
|
|
- Fixes RHBZ#1911390
|
|
|
|
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.0-3
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
|
|
|
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.0-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
|
|
|
* Thu Oct 31 16:11:54 EET 2019 Artem Polishchuk <ego.cordatus@gmail.com> - 1.0.0-1
|
|
- Initial package
|
|
|