commit
4f56a3b964
Binary file not shown.
@ -0,0 +1,26 @@
|
||||
--- polling-2.8.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ polling-2.8.0/Cargo.toml 2023-11-21T18:44:43.652491+00:00
|
||||
@@ -60,23 +60,3 @@
|
||||
[target."cfg(any(unix, target_os = \"fuchsia\", target_os = \"vxworks\"))".dependencies.libc]
|
||||
version = "0.2.77"
|
||||
|
||||
-[target."cfg(windows)".dependencies.bitflags]
|
||||
-version = "1.3.2"
|
||||
-
|
||||
-[target."cfg(windows)".dependencies.concurrent-queue]
|
||||
-version = "2.2.0"
|
||||
-
|
||||
-[target."cfg(windows)".dependencies.pin-project-lite]
|
||||
-version = "0.2.9"
|
||||
-
|
||||
-[target."cfg(windows)".dependencies.windows-sys]
|
||||
-version = "0.48"
|
||||
-features = [
|
||||
- "Win32_Foundation",
|
||||
- "Win32_Networking_WinSock",
|
||||
- "Win32_Storage_FileSystem",
|
||||
- "Win32_System_IO",
|
||||
- "Win32_System_LibraryLoader",
|
||||
- "Win32_System_Threading",
|
||||
- "Win32_System_WindowsProgramming",
|
||||
-]
|
@ -0,0 +1,98 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.3.5)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 1;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 25
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate polling
|
||||
|
||||
Name: rust-polling2
|
||||
Version: 2.8.0
|
||||
Release: %autorelease
|
||||
Summary: Portable interface to epoll, kqueue, event ports, and IOCP
|
||||
|
||||
License: Apache-2.0 OR MIT
|
||||
URL: https://crates.io/crates/polling
|
||||
Source: %{crates_source}
|
||||
# Automatically generated patch to strip dependencies and normalize metadata
|
||||
Patch: polling-fix-metadata-auto.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
Portable interface to epoll, kqueue, event ports, and IOCP.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+std-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+std-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "std" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+std-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 2.8.0-1
|
||||
- Rebuilt for MSVSphere 9.3
|
||||
|
||||
* Tue Nov 21 2023 Fabio Valentini <decathorpe@gmail.com> - 2.8.0-1
|
||||
- Initial import (polling 2 compat package)
|
Loading…
Reference in new issue