You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-pkcs8_0.7/SPECS/rust-pkcs8_0.7.spec

231 lines
6.3 KiB

## START: Set by rpmautospec
## (rpmautospec version 0.3.5)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 1;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate pkcs8
Name: rust-pkcs8_0.7
Version: 0.7.6
Release: %autorelease
Summary: Pure Rust implementation of PKCS#8 (RFC 5208 and RFC 5958)
License: Apache-2.0 OR MIT
URL: https://crates.io/crates/pkcs8
Source: %{crates_source}
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Pure Rust implementation of Public-Key Cryptography Standards (PKCS) #8:
Private-Key Information Syntax Specification (RFC 5208), with additional
support for PKCS#8v2 asymmetric key packages (RFC 5958).}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+3des-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+3des-devel %{_description}
This package contains library source intended for building other packages which
use the "3des" feature of the "%{crate}" crate.
%files -n %{name}+3des-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+alloc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages which
use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+des-insecure-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+des-insecure-devel %{_description}
This package contains library source intended for building other packages which
use the "des-insecure" feature of the "%{crate}" crate.
%files -n %{name}+des-insecure-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+encryption-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+encryption-devel %{_description}
This package contains library source intended for building other packages which
use the "encryption" feature of the "%{crate}" crate.
%files -n %{name}+encryption-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+pem-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+pem-devel %{_description}
This package contains library source intended for building other packages which
use the "pem" feature of the "%{crate}" crate.
%files -n %{name}+pem-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+pem-rfc7468-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+pem-rfc7468-devel %{_description}
This package contains library source intended for building other packages which
use the "pem-rfc7468" feature of the "%{crate}" crate.
%files -n %{name}+pem-rfc7468-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+pkcs1-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+pkcs1-devel %{_description}
This package contains library source intended for building other packages which
use the "pkcs1" feature of the "%{crate}" crate.
%files -n %{name}+pkcs1-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+pkcs5-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+pkcs5-devel %{_description}
This package contains library source intended for building other packages which
use the "pkcs5" feature of the "%{crate}" crate.
%files -n %{name}+pkcs5-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rand_core-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rand_core-devel %{_description}
This package contains library source intended for building other packages which
use the "rand_core" feature of the "%{crate}" crate.
%files -n %{name}+rand_core-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+sha1-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+sha1-devel %{_description}
This package contains library source intended for building other packages which
use the "sha1" feature of the "%{crate}" crate.
%files -n %{name}+sha1-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+zeroize-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+zeroize-devel %{_description}
This package contains library source intended for building other packages which
use the "zeroize" feature of the "%{crate}" crate.
%files -n %{name}+zeroize-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.7.6-1
- Rebuilt for MSVSphere 9.3
* Wed Jun 07 2023 Fabio Valentini <decathorpe@gmail.com> - 0.7.6-1
- Initial import (pkcs8 0.7 compat package)