You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-phf_shared0.8/rust-phf_shared0.8.spec

95 lines
2.1 KiB

# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate phf_shared
Name: rust-phf_shared0.8
Version: 0.8.0
Release: %autorelease
Summary: Support code shared by PHF libraries
License: MIT
URL: https://crates.io/crates/phf_shared
Source0: %{crates_source}
# https://github.com/sfackler/rust-phf/pull/118
Source1: https://github.com/rust-phf/rust-phf/raw/v%{version}/LICENSE
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Support code shared by PHF libraries.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unicase-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unicase-devel %{_description}
This package contains library source intended for building other packages which
use the "unicase" feature of the "%{crate}" crate.
%files -n %{name}+unicase-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
cp -pav %{SOURCE1} .
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog