You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-phf0.8/rust-phf0.8.spec

131 lines
3.2 KiB

# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate phf
Name: rust-phf0.8
Version: 0.8.0
Release: %autorelease
Summary: Runtime support for perfect hash function data structures
License: MIT
URL: https://crates.io/crates/phf
Source0: %{crates_source}
# https://github.com/sfackler/rust-phf/pull/118
Source1: https://github.com/rust-phf/rust-phf/raw/v%{version}/LICENSE
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Runtime support for perfect hash function data structures.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+macros-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+macros-devel %{_description}
This package contains library source intended for building other packages which
use the "macros" feature of the "%{crate}" crate.
%files -n %{name}+macros-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+phf_macros-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+phf_macros-devel %{_description}
This package contains library source intended for building other packages which
use the "phf_macros" feature of the "%{crate}" crate.
%files -n %{name}+phf_macros-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+proc-macro-hack-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+proc-macro-hack-devel %{_description}
This package contains library source intended for building other packages which
use the "proc-macro-hack" feature of the "%{crate}" crate.
%files -n %{name}+proc-macro-hack-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unicase-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unicase-devel %{_description}
This package contains library source intended for building other packages which
use the "unicase" feature of the "%{crate}" crate.
%files -n %{name}+unicase-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
cp -pav %{SOURCE1} .
%generate_buildrequires
%cargo_generate_buildrequires -a
%build
%cargo_build -a
%install
%cargo_install -a
%if %{with check}
%check
%cargo_test -a
%endif
%changelog
%autochangelog