You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-phf/rust-phf.spec

142 lines
3.5 KiB

# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate phf
Name: rust-phf
Version: 0.11.2
Release: %autorelease
Summary: Runtime support for perfect hash function data structures
License: MIT
URL: https://crates.io/crates/phf
Source: %{crates_source}
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Runtime support for perfect hash function data structures.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+macros-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+macros-devel %{_description}
This package contains library source intended for building other packages which
use the "macros" feature of the "%{crate}" crate.
%files -n %{name}+macros-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+phf_macros-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+phf_macros-devel %{_description}
This package contains library source intended for building other packages which
use the "phf_macros" feature of the "%{crate}" crate.
%files -n %{name}+phf_macros-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+uncased-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+uncased-devel %{_description}
This package contains library source intended for building other packages which
use the "uncased" feature of the "%{crate}" crate.
%files -n %{name}+uncased-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unicase-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unicase-devel %{_description}
This package contains library source intended for building other packages which
use the "unicase" feature of the "%{crate}" crate.
%files -n %{name}+unicase-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires -a
%build
%cargo_build -a
%install
%cargo_install -a
%if %{with check}
%check
%cargo_test -a
%endif
%changelog
%autochangelog