You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
237 lines
7.7 KiB
237 lines
7.7 KiB
## START: Set by rpmautospec
|
|
## (rpmautospec version 0.7.3)
|
|
## RPMAUTOSPEC: autorelease, autochangelog
|
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
|
release_number = 1;
|
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
|
print(release_number + base_release_number - 1);
|
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
|
## END: Set by rpmautospec
|
|
|
|
# Generated by rust2rpm 27
|
|
%bcond check 1
|
|
%global debug_package %{nil}
|
|
|
|
%global crate pest_derive
|
|
|
|
Name: rust-pest_derive
|
|
Version: 2.7.15
|
|
Release: %autorelease
|
|
Summary: Pest's derive macro
|
|
|
|
License: MIT OR Apache-2.0
|
|
URL: https://crates.io/crates/pest_derive
|
|
Source: %{crates_source}
|
|
# Manually created patch for downstream crate metadata changes
|
|
# * drop feature and dependencies for bootstrap build mode
|
|
Patch: pest_derive-fix-metadata.diff
|
|
|
|
BuildRequires: cargo-rpm-macros >= 24
|
|
|
|
%global _description %{expand:
|
|
Pest's derive macro.}
|
|
|
|
%description %{_description}
|
|
|
|
%package devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "%{crate}" crate.
|
|
|
|
%files devel
|
|
%license %{crate_instdir}/LICENSE-APACHE
|
|
%license %{crate_instdir}/LICENSE-MIT
|
|
%doc %{crate_instdir}/_README.md
|
|
%{crate_instdir}/
|
|
|
|
%package -n %{name}+default-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+default-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "default" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+default-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+grammar-extras-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+grammar-extras-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "grammar-extras" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+grammar-extras-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+std-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+std-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "std" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+std-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version} -p1
|
|
%cargo_prep
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires
|
|
|
|
%build
|
|
%cargo_build
|
|
|
|
%install
|
|
%cargo_install
|
|
|
|
%if %{with check}
|
|
%check
|
|
%cargo_test
|
|
%endif
|
|
|
|
%changelog
|
|
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 2.7.15-1
|
|
- Rebuilt for MSVSphere 10
|
|
|
|
## START: Generated by rpmautospec
|
|
* Mon Dec 16 2024 Fabio Valentini <decathorpe@gmail.com> - 2.7.15-1
|
|
- Update to version 2.7.15; Fixes RHBZ#2330943
|
|
|
|
* Wed Oct 23 2024 Fabio Valentini <decathorpe@gmail.com> - 2.7.14-1
|
|
- Update to version 2.7.14; Fixes RHBZ#2313573
|
|
|
|
* Wed Sep 18 2024 Fabio Valentini <decathorpe@gmail.com> - 2.7.12-1
|
|
- Update to version 2.7.12; Fixes RHBZ#2310442
|
|
|
|
* Sat Jul 20 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.11-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
|
|
|
* Sun Jul 07 2024 Fabio Valentini <decathorpe@gmail.com> - 2.7.11-1
|
|
- Update to version 2.7.11; Fixes RHBZ#2295546
|
|
|
|
* Tue Jun 25 2024 Fabio Valentini <decathorpe@gmail.com> - 2.7.10-1
|
|
- Update to version 2.7.10; Fixes RHBZ#2262744
|
|
|
|
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.6-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
|
|
|
* Sat Jan 13 2024 Fabio Valentini <decathorpe@gmail.com> - 2.7.6-1
|
|
- Update to version 2.7.6; Fixes RHBZ#2240742
|
|
|
|
* Tue Sep 19 2023 Fabio Valentini <decathorpe@gmail.com> - 2.7.3-1
|
|
- Update to version 2.7.3; Fixes RHBZ#2236146
|
|
|
|
* Sun Aug 27 2023 Fabio Valentini <decathorpe@gmail.com> - 2.7.2-1
|
|
- Update to version 2.7.2; Fixes RHBZ#2228091
|
|
|
|
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.1-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
|
|
|
* Mon Jul 17 2023 Fabio Valentini <decathorpe@gmail.com> - 2.7.1-1
|
|
- Update to version 2.7.1; Fixes RHBZ#2215706
|
|
|
|
* Thu May 04 2023 Fabio Valentini <decathorpe@gmail.com> - 2.6.0-1
|
|
- Update to version 2.6.0; Fixes RHBZ#2189951
|
|
|
|
* Sun Apr 02 2023 Fabio Valentini <decathorpe@gmail.com> - 2.5.7-1
|
|
- Update to version 2.5.7; Fixes RHBZ#2183405
|
|
|
|
* Thu Mar 16 2023 Fabio Valentini <decathorpe@gmail.com> - 2.5.6-1
|
|
- Update to version 2.5.6; Fixes RHBZ#2175456
|
|
|
|
* Tue Feb 28 2023 Fabio Valentini <decathorpe@gmail.com> - 2.5.5-1
|
|
- Update to version 2.5.5; Fixes RHBZ#2168005
|
|
|
|
* Fri Feb 03 2023 Fabio Valentini <decathorpe@gmail.com> - 2.5.4-1
|
|
- Update to version 2.5.4; Fixes RHBZ#2140177
|
|
|
|
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.0-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
|
|
|
* Sat Oct 08 2022 Fabio Valentini <decathorpe@gmail.com> - 2.4.0-1
|
|
- Update to version 2.4.0; Fixes RHBZ#2125968
|
|
|
|
* Sun Aug 21 2022 Fabio Valentini <decathorpe@gmail.com> - 2.3.0-1
|
|
- Update to version 2.3.0; Fixes RHBZ#2112464
|
|
|
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.0-10
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
|
|
|
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.0-9
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
|
|
|
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.0-8
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
|
|
|
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.0-7
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
|
|
|
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.0-6
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
|
|
|
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.0-5
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
|
|
|
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.0-4
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
|
|
|
* Thu Jun 20 00:17:27 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.1.0-3
|
|
- Regenerate
|
|
|
|
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.0-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
|
|
|
* Tue Jan 08 2019 Josh Stone <jistone@redhat.com> - 2.1.0-1
|
|
- Update to 2.1.0
|
|
|
|
* Sat Nov 10 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.0.1-1
|
|
- Update to 2.0.1
|
|
|
|
* Fri Nov 09 2018 Josh Stone <jistone@redhat.com> - 1.0.8-2
|
|
- Adapt to new packaging
|
|
|
|
* Sat Sep 08 2018 Josh Stone <jistone@redhat.com> - 1.0.8-1
|
|
- Update to 1.0.8
|
|
|
|
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.7-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
|
|
|
* Thu Jun 14 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.0.7-1
|
|
- Update to 1.0.7
|
|
|
|
* Fri Feb 23 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.0.6-2
|
|
- Restore spec
|
|
|
|
* Fri Feb 23 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.0.6-1
|
|
- Update to 1.0.6
|
|
|
|
* Mon Feb 19 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.0.5-1
|
|
- Update to 1.0.5
|
|
|
|
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.3-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
|
|
|
* Fri Jan 26 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.0.3-1
|
|
- Update to 1.0.3
|
|
|
|
* Tue Jan 23 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.0.2-1
|
|
- Update to 1.0.2
|
|
|
|
* Sun Jan 21 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.0.1-1
|
|
- Initial package
|
|
|
|
## END: Generated by rpmautospec
|