parent
1e5ae2bdf2
commit
96d32bfba8
@ -0,0 +1 @@
|
||||
/pem-rfc7468-0.2.4.crate
|
@ -1,3 +0,0 @@
|
||||
# rust-pem-rfc7468_0.2
|
||||
|
||||
The rust-pem-rfc7468_0.2 package
|
@ -0,0 +1,11 @@
|
||||
--- pem-rfc7468-0.2.4/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||
+++ pem-rfc7468-0.2.4/Cargo.toml 2023-05-30T13:32:29.606366+00:00
|
||||
@@ -25,7 +25,7 @@
|
||||
all-features = true
|
||||
rustdoc-args = ["--cfg", "docsrs"]
|
||||
[dependencies.base64ct]
|
||||
-version = ">=1, <1.2"
|
||||
+version = "1"
|
||||
|
||||
[features]
|
||||
alloc = []
|
@ -0,0 +1,101 @@
|
||||
# Generated by rust2rpm 24
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate pem-rfc7468
|
||||
|
||||
Name: rust-pem-rfc7468_0.2
|
||||
Version: 0.2.4
|
||||
Release: %autorelease
|
||||
Summary: PEM Encoding (RFC 7468) for PKIX, PKCS, and CMS Structures
|
||||
|
||||
License: Apache-2.0 OR MIT
|
||||
URL: https://crates.io/crates/pem-rfc7468
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * relax base64ct dependency (MSRV is irrelevant in Fedora)
|
||||
Patch: pem-rfc7468-fix-metadata.diff
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
PEM Encoding (RFC 7468) for PKIX, PKCS, and CMS Structures, implementing
|
||||
a strict subset of the original Privacy-Enhanced Mail encoding intended
|
||||
specifically for use with cryptographic keys, certificates, and other
|
||||
messages. Provides a no_std-friendly, constant-time implementation
|
||||
suitable for use with cryptographic private keys.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+alloc-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+alloc-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "alloc" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+alloc-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+std-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+std-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "std" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+std-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
Loading…
Reference in new issue