You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-pbkdf2_0.9/SPECS/rust-pbkdf2_0.9.spec

181 lines
4.7 KiB

## START: Set by rpmautospec
## (rpmautospec version 0.3.5)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 1;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate pbkdf2
Name: rust-pbkdf2_0.9
Version: 0.9.0
Release: %autorelease
Summary: Generic implementation of PBKDF2
License: MIT OR Apache-2.0
URL: https://crates.io/crates/pbkdf2
Source: %{crates_source}
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Generic implementation of PBKDF2.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+hmac-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+hmac-devel %{_description}
This package contains library source intended for building other packages which
use the "hmac" feature of the "%{crate}" crate.
%files -n %{name}+hmac-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+parallel-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+parallel-devel %{_description}
This package contains library source intended for building other packages which
use the "parallel" feature of the "%{crate}" crate.
%files -n %{name}+parallel-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+password-hash-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+password-hash-devel %{_description}
This package contains library source intended for building other packages which
use the "password-hash" feature of the "%{crate}" crate.
%files -n %{name}+password-hash-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rayon-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rayon-devel %{_description}
This package contains library source intended for building other packages which
use the "rayon" feature of the "%{crate}" crate.
%files -n %{name}+rayon-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+sha1-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+sha1-devel %{_description}
This package contains library source intended for building other packages which
use the "sha1" feature of the "%{crate}" crate.
%files -n %{name}+sha1-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+sha2-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+sha2-devel %{_description}
This package contains library source intended for building other packages which
use the "sha2" feature of the "%{crate}" crate.
%files -n %{name}+sha2-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+simple-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+simple-devel %{_description}
This package contains library source intended for building other packages which
use the "simple" feature of the "%{crate}" crate.
%files -n %{name}+simple-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.9.0-1
- Rebuilt for MSVSphere 9.3
* Wed Mar 08 2023 Fabio Valentini <decathorpe@gmail.com> - 0.9.0-1
- Initial import (pbkdf2 0.9 compat package)