You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-path-dedot/rust-path-dedot.spec

130 lines
3.3 KiB

# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate path-dedot
Name: rust-path-dedot
Version: 3.1.1
Release: %autorelease
Summary: Parse path with dots in Path and PathBuf
License: MIT
URL: https://crates.io/crates/path-dedot
Source: %{crates_source}
BuildRequires: rust-packaging >= 21
%global _description %{expand:
A library for extending `Path` and `PathBuf` in order to parse the path
which contains dots.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+lazy_static-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+lazy_static-devel %{_description}
This package contains library source intended for building other packages which
use the "lazy_static" feature of the "%{crate}" crate.
%files -n %{name}+lazy_static-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+lazy_static_cache-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+lazy_static_cache-devel %{_description}
This package contains library source intended for building other packages which
use the "lazy_static_cache" feature of the "%{crate}" crate.
%files -n %{name}+lazy_static_cache-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+once_cell_cache-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+once_cell_cache-devel %{_description}
This package contains library source intended for building other packages which
use the "once_cell_cache" feature of the "%{crate}" crate.
%files -n %{name}+once_cell_cache-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unsafe_cache-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unsafe_cache-devel %{_description}
This package contains library source intended for building other packages which
use the "unsafe_cache" feature of the "%{crate}" crate.
%files -n %{name}+unsafe_cache-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+use_unix_paths_on_wasm-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+use_unix_paths_on_wasm-devel %{_description}
This package contains library source intended for building other packages which
use the "use_unix_paths_on_wasm" feature of the "%{crate}" crate.
%files -n %{name}+use_unix_paths_on_wasm-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog