parent
8d406a89f1
commit
65e67982e2
@ -0,0 +1 @@
|
||||
/parking_lot-0.6.4.crate
|
@ -0,0 +1,10 @@
|
||||
--- parking_lot-0.6.4/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||
+++ parking_lot-0.6.4/Cargo.toml 2018-09-03T09:29:36.345745+02:00
|
||||
@@ -29,7 +29,5 @@
|
||||
version = "0.5"
|
||||
|
||||
[features]
|
||||
-deadlock_detection = ["parking_lot_core/deadlock_detection"]
|
||||
default = ["owning_ref"]
|
||||
-nightly = ["parking_lot_core/nightly", "lock_api/nightly"]
|
||||
owning_ref = ["lock_api/owning_ref"]
|
@ -0,0 +1,69 @@
|
||||
# Generated by rust2rpm
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate parking_lot
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.6.4
|
||||
Release: 1%{?dist}
|
||||
Summary: Compact and efficient implementations of standard synchronization primitives
|
||||
|
||||
# Upstream license specification: Apache-2.0/MIT
|
||||
License: ASL 2.0 or MIT
|
||||
URL: https://crates.io/crates/parking_lot
|
||||
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||
# Initial patched metadata
|
||||
# * No nightly
|
||||
# * No deadlock_detection in parking_lot_core
|
||||
Patch0: parking_lot-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
# [dependencies]
|
||||
BuildRequires: (crate(lock_api) >= 0.1.0 with crate(lock_api) < 0.2.0)
|
||||
BuildRequires: (crate(parking_lot_core) >= 0.3.0 with crate(parking_lot_core) < 0.4.0)
|
||||
%if %{with check}
|
||||
# [dev-dependencies]
|
||||
BuildRequires: (crate(rand) >= 0.5.0 with crate(rand) < 0.6.0)
|
||||
%endif
|
||||
|
||||
%description
|
||||
%{summary}.
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel
|
||||
More compact and efficient implementations of the standard synchronization
|
||||
primitives.
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use %{crate} from crates.io.
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%files devel
|
||||
%license LICENSE-MIT LICENSE-APACHE
|
||||
%doc README.md CHANGELOG.md
|
||||
%{cargo_registry}/%{crate}-%{version}/
|
||||
%exclude %{cargo_registry}/%{crate}-%{version}/appveyor.yml
|
||||
|
||||
%changelog
|
||||
* Mon Sep 03 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.4-1
|
||||
- Initial package
|
Loading…
Reference in new issue