Update to 0.8.0

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent 8daed26829
commit 29fbff63f2
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -1,3 +1,4 @@
/parking_lot-0.6.4.crate
/parking_lot-0.7.0.crate
/parking_lot-0.7.1.crate
/parking_lot-0.8.0.crate

@ -1,10 +0,0 @@
--- parking_lot-0.7.0/Cargo.toml 1970-01-01T01:00:00+01:00
+++ parking_lot-0.7.0/Cargo.toml 2018-12-15T10:00:50.025562+01:00
@@ -29,7 +29,5 @@
version = "0.6"
[features]
-deadlock_detection = ["parking_lot_core/deadlock_detection"]
default = ["owning_ref"]
-nightly = ["parking_lot_core/nightly", "lock_api/nightly"]
owning_ref = ["lock_api/owning_ref"]

@ -1,31 +1,28 @@
# Generated by rust2rpm
# * Tests are run in infrastructure
# Generated by rust2rpm-9-1.fc31
%bcond_with check
%global debug_package %{nil}
%global crate parking_lot
Name: rust-%{crate}
Version: 0.7.1
Release: 2%{?dist}
Version: 0.8.0
Release: 1%{?dist}
Summary: Compact and efficient implementations of standard synchronization primitives
# Upstream license specification: Apache-2.0/MIT
License: ASL 2.0 or MIT
URL: https://crates.io/crates/parking_lot
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * No nightly
# * No deadlock_detection in parking_lot_core
Patch0: parking_lot-fix-metadata.diff
Source: %{crates_source}
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: (crate(lock_api/default) >= 0.1.0 with crate(lock_api/default) < 0.2.0)
BuildRequires: (crate(lock_api/owning_ref) >= 0.1.0 with crate(lock_api/owning_ref) < 0.2.0)
BuildRequires: (crate(parking_lot_core/default) >= 0.4.0 with crate(parking_lot_core/default) < 0.5.0)
BuildRequires: (crate(lock_api/default) >= 0.2.0 with crate(lock_api/default) < 0.3.0)
BuildRequires: (crate(parking_lot_core/default) >= 0.5.0 with crate(parking_lot_core/default) < 0.6.0)
BuildRequires: (crate(rustc_version/default) >= 0.2.0 with crate(rustc_version/default) < 0.3.0)
%if %{with check}
BuildRequires: (crate(bincode/default) >= 1.1.3 with crate(bincode/default) < 2.0.0)
BuildRequires: (crate(lazy_static/default) >= 1.0.0 with crate(lazy_static/default) < 2.0.0)
BuildRequires: (crate(rand/default) >= 0.6.0 with crate(rand/default) < 0.7.0)
%endif
@ -61,6 +58,30 @@ which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+deadlock_detection-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+deadlock_detection-devel %{_description}
This package contains library source intended for building other packages
which use "deadlock_detection" feature of "%{crate}" crate.
%files -n %{name}+deadlock_detection-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+nightly-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+nightly-devel %{_description}
This package contains library source intended for building other packages
which use "nightly" feature of "%{crate}" crate.
%files -n %{name}+nightly-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+owning_ref-devel
Summary: %{summary}
BuildArch: noarch
@ -73,8 +94,20 @@ which use "owning_ref" feature of "%{crate}" crate.
%files -n %{name}+owning_ref-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages
which use "serde" feature of "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%build
@ -89,6 +122,9 @@ which use "owning_ref" feature of "%{crate}" crate.
%endif
%changelog
* Mon May 06 15:48:12 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.8.0-1
- Update to 0.8.0
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

@ -1 +1 @@
SHA512 (parking_lot-0.7.1.crate) = d83d3c457e15ffce500d4fc82d0b9840ea2ed36d43d4eca841b05b0a9ee73ff6fcce07ccc3a6f0d06d950d7beff85db0c3d13dc1461adfef390d6b3d85367bed
SHA512 (parking_lot-0.8.0.crate) = 82937f87811a987652fad9c4018efa2dd214b4142c5a94c6629fc5bb0e9c49c13d9503783e3932fd0834f2a1afde6dce80aa488b2bcd32c95bf9a9d5ce139f93

Loading…
Cancel
Save