parent
1b0abb676f
commit
f0f5561dea
@ -1,41 +0,0 @@
|
|||||||
From 9e0a872ece6f5aedf76ffd67044f22c7d0cba8aa Mon Sep 17 00:00:00 2001
|
|
||||||
From: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
|
|
||||||
Date: Fri, 20 Oct 2017 18:04:31 +0200
|
|
||||||
Subject: [PATCH 1/3] inspector: inject cargo dependency in runtime
|
|
||||||
|
|
||||||
Fixes: https://pagure.io/fedora-rust/rust2rpm/issue/42
|
|
||||||
Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
|
|
||||||
---
|
|
||||||
rust2rpm/__main__.py | 1 +
|
|
||||||
rust2rpm/inspector.py | 3 +++
|
|
||||||
2 files changed, 4 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/rust2rpm/__main__.py b/rust2rpm/__main__.py
|
|
||||||
index 0121a33..bb92fa3 100644
|
|
||||||
--- a/rust2rpm/__main__.py
|
|
||||||
+++ b/rust2rpm/__main__.py
|
|
||||||
@@ -91,6 +91,7 @@ Provides: {{ prv }}
|
|
||||||
{% endfor %}
|
|
||||||
{% endif %}
|
|
||||||
{% if include_requires %}
|
|
||||||
+Requires: cargo
|
|
||||||
{% if md.requires|length > 0 %}
|
|
||||||
# [dependencies]
|
|
||||||
{% for req in md.requires|sort(attribute="name") %}
|
|
||||||
diff --git a/rust2rpm/inspector.py b/rust2rpm/inspector.py
|
|
||||||
index d08f1aa..6ccdbc2 100644
|
|
||||||
--- a/rust2rpm/inspector.py
|
|
||||||
+++ b/rust2rpm/inspector.py
|
|
||||||
@@ -38,6 +38,9 @@ def main():
|
|
||||||
print_deps(list(itertools.chain(md.requires, md.build_requires)))
|
|
||||||
if args.test_requires:
|
|
||||||
print_deps(md.test_requires)
|
|
||||||
+ if args.requires:
|
|
||||||
+ # Someone should own /usr/share/cargo/registry
|
|
||||||
+ print("cargo")
|
|
||||||
|
|
||||||
if __name__ == "__main__":
|
|
||||||
main()
|
|
||||||
--
|
|
||||||
2.15.0
|
|
||||||
|
|
@ -1,28 +0,0 @@
|
|||||||
From 45a5caf30060c182fb0ae03a1a7e4e707599aaa3 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
|
|
||||||
Date: Sat, 21 Oct 2017 09:45:30 +0200
|
|
||||||
Subject: [PATCH 2/3] inspector: inject rust-packaging dependency in buildtime
|
|
||||||
|
|
||||||
For consistency with previous commit.
|
|
||||||
|
|
||||||
Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
|
|
||||||
---
|
|
||||||
rust2rpm/inspector.py | 2 ++
|
|
||||||
1 file changed, 2 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/rust2rpm/inspector.py b/rust2rpm/inspector.py
|
|
||||||
index 6ccdbc2..2d488b2 100644
|
|
||||||
--- a/rust2rpm/inspector.py
|
|
||||||
+++ b/rust2rpm/inspector.py
|
|
||||||
@@ -41,6 +41,8 @@ def main():
|
|
||||||
if args.requires:
|
|
||||||
# Someone should own /usr/share/cargo/registry
|
|
||||||
print("cargo")
|
|
||||||
+ if args.build_requires:
|
|
||||||
+ print("rust-packaging")
|
|
||||||
|
|
||||||
if __name__ == "__main__":
|
|
||||||
main()
|
|
||||||
--
|
|
||||||
2.15.0
|
|
||||||
|
|
@ -1,31 +0,0 @@
|
|||||||
From 59809d4940822edaa361507ecea93b84e3c43ec0 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
|
|
||||||
Date: Sat, 4 Nov 2017 15:32:39 +0100
|
|
||||||
Subject: [PATCH 3/3] use cp instead of install
|
|
||||||
|
|
||||||
We want to preserve original modes and so on.
|
|
||||||
|
|
||||||
Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
|
|
||||||
---
|
|
||||||
data/macros.cargo | 4 ++--
|
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/data/macros.cargo b/data/macros.cargo
|
|
||||||
index 09bbcea..e52f87c 100644
|
|
||||||
--- a/data/macros.cargo
|
|
||||||
+++ b/data/macros.cargo
|
|
||||||
@@ -45,9 +45,9 @@ if %__cargo_is_lib; then \
|
|
||||||
CRATE_VERSION=$(%__cargo_inspector --version Cargo.toml) \
|
|
||||||
REG_DIR=%{buildroot}%{cargo_registry}/$CRATE_NAME-$CRATE_VERSION \
|
|
||||||
%{__mkdir} -p $REG_DIR \
|
|
||||||
- %__cargo package -l | xargs cp --parents -p -t $REG_DIR \
|
|
||||||
+ %__cargo package -l | xargs %{__cp} --parents -a -t $REG_DIR \
|
|
||||||
%if ! %{with check} \
|
|
||||||
- %{__install} -p Cargo.toml.orig $REG_DIR/Cargo.toml \
|
|
||||||
+ %{__cp} -a Cargo.toml.orig $REG_DIR/Cargo.toml \
|
|
||||||
%endif \
|
|
||||||
echo '{"files":{},"package":""}' > $REG_DIR/.cargo-checksum.json \
|
|
||||||
fi \
|
|
||||||
--
|
|
||||||
2.15.0
|
|
||||||
|
|
Loading…
Reference in new issue