|
|
@ -1,4 +1,4 @@
|
|
|
|
From 83a9b92d68e8c5d6f2ab75b287be7ea69275fb90 Mon Sep 17 00:00:00 2001
|
|
|
|
From 571ba6b1f2a886b40a7de76980cd8c479015cc9e Mon Sep 17 00:00:00 2001
|
|
|
|
From: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
|
|
|
|
From: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
|
|
|
|
Date: Fri, 26 Oct 2018 11:20:13 +0200
|
|
|
|
Date: Fri, 26 Oct 2018 11:20:13 +0200
|
|
|
|
Subject: [PATCH 7/7] split features into subpackages
|
|
|
|
Subject: [PATCH 7/7] split features into subpackages
|
|
|
@ -512,7 +512,7 @@ index 5adeb65..95aa142 100644
|
|
|
|
+def normalize_deps(deps):
|
|
|
|
+def normalize_deps(deps):
|
|
|
|
+ return set().union(*(d.normalize() for d in deps))
|
|
|
|
+ return set().union(*(d.normalize() for d in deps))
|
|
|
|
diff --git a/rust2rpm/templates/main.spec b/rust2rpm/templates/main.spec
|
|
|
|
diff --git a/rust2rpm/templates/main.spec b/rust2rpm/templates/main.spec
|
|
|
|
index 7dbcc3f..4acfab7 100644
|
|
|
|
index 7dbcc3f..27a448f 100644
|
|
|
|
--- a/rust2rpm/templates/main.spec
|
|
|
|
--- a/rust2rpm/templates/main.spec
|
|
|
|
+++ b/rust2rpm/templates/main.spec
|
|
|
|
+++ b/rust2rpm/templates/main.spec
|
|
|
|
@@ -48,82 +48,101 @@ Patch0: {{ patch_file }}
|
|
|
|
@@ -48,82 +48,101 @@ Patch0: {{ patch_file }}
|
|
|
@ -613,7 +613,7 @@ index 7dbcc3f..4acfab7 100644
|
|
|
|
-{% endif %}
|
|
|
|
-{% endif %}
|
|
|
|
-{% if include_requires %}
|
|
|
|
-{% if include_requires %}
|
|
|
|
+ {% if include_provides %}
|
|
|
|
+ {% if include_provides %}
|
|
|
|
+Provides: {{ md.provides() }}
|
|
|
|
+Provides: {{ md.provides(feature) }}
|
|
|
|
+ {% endif %}
|
|
|
|
+ {% endif %}
|
|
|
|
+ {% if include_requires %}
|
|
|
|
+ {% if include_requires %}
|
|
|
|
Requires: cargo
|
|
|
|
Requires: cargo
|
|
|
@ -644,7 +644,7 @@ index 7dbcc3f..4acfab7 100644
|
|
|
|
|
|
|
|
|
|
|
|
This package contains library source intended for building other packages
|
|
|
|
This package contains library source intended for building other packages
|
|
|
|
-which use %{crate} from crates.io.
|
|
|
|
-which use %{crate} from crates.io.
|
|
|
|
+which use {% if feature is not none %}"{{ feature }}" of {% endif %}"%{crate}" crate.
|
|
|
|
+which use {% if feature is not none %}"{{ feature }}" feature of {% endif %}"%{crate}" crate.
|
|
|
|
+
|
|
|
|
+
|
|
|
|
+%files {{ pkg }}
|
|
|
|
+%files {{ pkg }}
|
|
|
|
+ {% if feature is none %}
|
|
|
|
+ {% if feature is none %}
|
|
|
|