You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-os_pipe0.9/rust-os_pipe0.9.spec

77 lines
1.6 KiB

# Generated by rust2rpm 20
# * tests require building the example binaries
%bcond_with check
%global debug_package %{nil}
%global crate os_pipe
Name: rust-%{crate}0.9
Version: 0.9.2
Release: %autorelease
Summary: Cross-platform library for opening OS pipes
# Upstream license specification: MIT
License: MIT
URL: https://crates.io/crates/os_pipe
Source: %{crates_source}
# Initial patched metadata
# * drop windows-specific dependencies
# * drop unwanted example binaries
Patch0: os_pipe-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
%global _description %{expand:
Cross-platform library for opening OS pipes.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE
%doc README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog