commit
54cbc40a6e
Binary file not shown.
@ -0,0 +1,14 @@
|
||||
--- os_pipe-1.1.5/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ os_pipe-1.1.5/Cargo.toml 2023-12-31T16:32:25.209713+00:00
|
||||
@@ -35,11 +35,3 @@
|
||||
[target."cfg(not(windows))".dependencies.libc]
|
||||
version = "0.2.62"
|
||||
|
||||
-[target."cfg(windows)".dependencies.windows-sys]
|
||||
-version = "0.52.0"
|
||||
-features = [
|
||||
- "Win32_Foundation",
|
||||
- "Win32_System_Pipes",
|
||||
- "Win32_Security",
|
||||
- "Win32_System_Threading",
|
||||
-]
|
@ -0,0 +1,10 @@
|
||||
--- os_pipe-1.1.5/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ os_pipe-1.1.5/Cargo.toml 2023-12-31T16:32:29.819737+00:00
|
||||
@@ -25,6 +25,7 @@
|
||||
]
|
||||
license = "MIT"
|
||||
repository = "https://github.com/oconnor663/os_pipe.rs"
|
||||
+autobins = false
|
||||
|
||||
[package.metadata.docs.rs]
|
||||
features = ["io_safety"]
|
@ -0,0 +1,158 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.3.5)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 1;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 25
|
||||
# * tests require building the example binaries
|
||||
%bcond_with check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate os_pipe
|
||||
|
||||
Name: rust-os_pipe
|
||||
Version: 1.1.5
|
||||
Release: %autorelease
|
||||
Summary: Cross-platform library for opening OS pipes
|
||||
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/os_pipe
|
||||
Source: %{crates_source}
|
||||
# Automatically generated patch to strip dependencies and normalize metadata
|
||||
Patch: os_pipe-fix-metadata-auto.diff
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * drop unwanted example binaries
|
||||
Patch: os_pipe-fix-metadata.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
A cross-platform library for opening OS pipes.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+io_safety-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+io_safety-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "io_safety" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+io_safety-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 1.1.5-1
|
||||
- Rebuilt for MSVSphere 9.3
|
||||
|
||||
* Sun Dec 31 2023 Fabio Valentini <decathorpe@gmail.com> - 1.1.5-1
|
||||
- Update to version 1.1.5; Fixes RHBZ#2256241
|
||||
|
||||
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.4-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
* Sat Apr 22 2023 Fabio Valentini <decathorpe@gmail.com> - 1.1.4-1
|
||||
- Update to version 1.1.4; Fixes RHBZ#2188747
|
||||
|
||||
* Fri Feb 03 2023 Fabio Valentini <decathorpe@gmail.com> - 1.1.3-1
|
||||
- Update to version 1.1.3; Fixes RHBZ#2166736
|
||||
|
||||
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Sun Dec 04 2022 Fabio Valentini <decathorpe@gmail.com> - 1.1.2-1
|
||||
- Update to version 1.1.2; Fixes RHBZ#2148538
|
||||
|
||||
* Wed Oct 05 2022 Fabio Valentini <decathorpe@gmail.com> - 1.1.1-1
|
||||
- Update to version 1.1.1; Fixes RHBZ#2131494
|
||||
|
||||
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Fri Feb 25 2022 Fabio Valentini <decathorpe@gmail.com> - 1.0.1-1
|
||||
- Update to version 1.0.1; Fixes RHBZ#2058366
|
||||
|
||||
* Thu Feb 03 2022 Fabio Valentini <decathorpe@gmail.com> - 1.0.0-1
|
||||
- Update to version 1.0.0; Fixes RHBZ#2023887
|
||||
|
||||
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.2-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.2-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.2-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Sat May 30 2020 Josh Stone <jistone@redhat.com> - 0.9.2-1
|
||||
- Update to 0.9.2
|
||||
|
||||
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Tue Nov 19 2019 Josh Stone <jistone@redhat.com> - 0.9.1-1
|
||||
- Update to 0.9.1
|
||||
|
||||
* Sun Sep 08 16:09:00 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.8.2-1
|
||||
- Update to 0.8.2
|
||||
|
||||
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Sun Jul 07 16:18:21 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.8.1-1
|
||||
- Initial package
|
||||
|
Loading…
Reference in new issue