You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-ordered-float2/SPECS/rust-ordered-float2.spec

176 lines
4.7 KiB

## START: Set by rpmautospec
## (rpmautospec version 0.3.5)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 1;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}
%global crate ordered-float
Name: rust-ordered-float2
Version: 2.10.1
Release: %autorelease
Summary: Wrappers for total ordering on floats
License: MIT
URL: https://crates.io/crates/ordered-float
Source: %{crates_source}
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Wrappers for total ordering on floats.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+arbitrary-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+arbitrary-devel %{_description}
This package contains library source intended for building other packages which
use the "arbitrary" feature of the "%{crate}" crate.
%files -n %{name}+arbitrary-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+proptest-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+proptest-devel %{_description}
This package contains library source intended for building other packages which
use the "proptest" feature of the "%{crate}" crate.
%files -n %{name}+proptest-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rand-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rand-devel %{_description}
This package contains library source intended for building other packages which
use the "rand" feature of the "%{crate}" crate.
%files -n %{name}+rand-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+randtest-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+randtest-devel %{_description}
This package contains library source intended for building other packages which
use the "randtest" feature of the "%{crate}" crate.
%files -n %{name}+randtest-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rkyv-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rkyv-devel %{_description}
This package contains library source intended for building other packages which
use the "rkyv" feature of the "%{crate}" crate.
%files -n %{name}+rkyv-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 2.10.1-1
- Rebuilt for MSVSphere 9.3
* Mon Nov 13 2023 Fabio Valentini <decathorpe@gmail.com> - 2.10.1-1
- Update to version 2.10.1
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.10.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.10.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Wed Jul 27 2022 Fabio Valentini <decathorpe@gmail.com> - 2.10.0-1
- Initial import (ordered-float 2 compat package)