You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
125 lines
3.1 KiB
125 lines
3.1 KiB
# Generated by rust2rpm 22
|
|
%bcond_without check
|
|
%global debug_package %{nil}
|
|
|
|
%global crate onig
|
|
|
|
Name: rust-onig
|
|
Version: 6.4.0
|
|
Release: %autorelease
|
|
Summary: Rust bindings for the Oniguruma regular expression library
|
|
|
|
License: MIT
|
|
URL: https://crates.io/crates/onig
|
|
Source: %{crates_source}
|
|
# Automatically generated patch to strip foreign dependencies
|
|
Patch: onig-fix-metadata-auto.diff
|
|
# Restore compatibility with oniguruma 6.9.6
|
|
Patch: onig-696-compat.diff
|
|
|
|
ExclusiveArch: %{rust_arches}
|
|
|
|
BuildRequires: rust-packaging >= 21
|
|
|
|
%global _description %{expand:
|
|
Rust-Onig is a set of Rust bindings for the Oniguruma regular expression
|
|
library. Oniguruma is a modern regex library with support for multiple
|
|
character encodings and regex syntaxes.}
|
|
|
|
%description %{_description}
|
|
|
|
%package devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "%{crate}" crate.
|
|
|
|
%files devel
|
|
%license %{crate_instdir}/LICENSE.md
|
|
%doc %{crate_instdir}/README.md
|
|
%{crate_instdir}/
|
|
|
|
%package -n %{name}+default-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+default-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "default" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+default-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+generate-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+generate-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "generate" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+generate-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+posix-api-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+posix-api-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "posix-api" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+posix-api-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+print-debug-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+print-debug-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "print-debug" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+print-debug-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+std-pattern-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+std-pattern-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "std-pattern" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+std-pattern-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
|
%cargo_prep
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires
|
|
|
|
%build
|
|
%cargo_build
|
|
|
|
%install
|
|
%cargo_install
|
|
|
|
%if %{with check}
|
|
%check
|
|
%cargo_test
|
|
%endif
|
|
|
|
%changelog
|
|
%autochangelog
|