parent
a7047a6df7
commit
fec23fd41d
@ -0,0 +1,29 @@
|
||||
From 32cd3651571477dd263f454da19123a0db89ceab Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Jan=20Stan=C4=9Bk?= <jstanek@redhat.com>
|
||||
Date: Thu, 7 Feb 2019 17:00:34 +0100
|
||||
Subject: [PATCH] Loosen parking_lot dependency constraints
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Signed-off-by: Jan Staněk <jstanek@redhat.com>
|
||||
---
|
||||
Cargo.toml | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Cargo.toml b/Cargo.toml
|
||||
index b26e4ce..4d44080 100644
|
||||
--- a/Cargo.toml
|
||||
+++ b/Cargo.toml
|
||||
@@ -23,7 +23,7 @@ categories = ["rust-patterns", "memory-management"]
|
||||
license = "MIT OR Apache-2.0"
|
||||
repository = "https://github.com/matklad/once_cell"
|
||||
[dependencies.parking_lot]
|
||||
-version = "0.7.1"
|
||||
+version = ">=0.6.4,<0.8.0"
|
||||
optional = true
|
||||
default_features = false
|
||||
[dev-dependencies.crossbeam-utils]
|
||||
--
|
||||
2.20.1
|
||||
|
@ -0,0 +1,26 @@
|
||||
From 5bec30616b685f4b0dea254ea149dd352c6ad097 Mon Sep 17 00:00:00 2001
|
||||
From: rpm-build <rpm-build>
|
||||
Date: Fri, 8 Feb 2019 16:19:26 +0100
|
||||
Subject: [PATCH 2/2] Exclude unnecessary files
|
||||
|
||||
Signed-off-by: rpm-build <rpm-build>
|
||||
---
|
||||
Cargo.toml | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Cargo.toml b/Cargo.toml
|
||||
index 4d44080..7168f37 100644
|
||||
--- a/Cargo.toml
|
||||
+++ b/Cargo.toml
|
||||
@@ -14,7 +14,7 @@
|
||||
name = "once_cell"
|
||||
version = "0.1.8"
|
||||
authors = ["Aleksey Kladov <aleksey.kladov@gmail.com>"]
|
||||
-exclude = ["*.png", "*.svg"]
|
||||
+exclude = ["*.png", "*.svg", "/.travis.yml", "/examples/*", "/Cargo.lock.min"]
|
||||
description = "Single assignment cells and lazy static values without macros."
|
||||
documentation = "https://docs.rs/once_cell"
|
||||
readme = "README.md"
|
||||
--
|
||||
2.20.1
|
||||
|
Binary file not shown.
@ -0,0 +1,66 @@
|
||||
# Generated by rust2rpm
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate once_cell
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.1.8
|
||||
Release: 1%{?dist}
|
||||
Summary: Single assignment cells and lazy static values without macros
|
||||
|
||||
# Upstream license specification: MIT OR Apache-2.0
|
||||
License: MIT or ASL 2.0
|
||||
URL: https://crates.io/crates/once_cell
|
||||
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||
|
||||
# Allow F29 builds
|
||||
Patch0: 0001-Loosen-parking_lot-dependency-constraints.patch
|
||||
Patch1: 0002-Exclude-unnecessary-files.patch
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
# [dependencies]
|
||||
BuildRequires: (crate(parking_lot) >= 0.6.4 with crate(parking_lot) < 0.8.0)
|
||||
%if %{with check}
|
||||
# [dev-dependencies]
|
||||
BuildRequires: (crate(crossbeam-utils/default) >= 0.6.0 with crate(crossbeam-utils/default) < 0.7.0)
|
||||
%endif
|
||||
|
||||
%description
|
||||
%{summary}.
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel
|
||||
Single assignment cells and lazy static values without macros.
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use %{crate} from crates.io.
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%files devel
|
||||
%license LICENSE-APACHE LICENSE-MIT
|
||||
%doc README.md CHANGELOG.md
|
||||
%{cargo_registry}/%{crate}-%{version}/
|
||||
|
||||
%changelog
|
||||
* Thu Feb 07 2019 Jan Stanek <jstanek@redhat.com> - 0.1.8-1
|
||||
- Initial package
|
Loading…
Reference in new issue