diff --git a/.gitignore b/.gitignore
index f62268a..3583225 100644
--- a/.gitignore
+++ b/.gitignore
@@ -26,3 +26,4 @@
 /once_cell-1.13.1.crate
 /once_cell-1.14.0.crate
 /once_cell-1.15.0.crate
+/once_cell-1.16.0.crate
diff --git a/rust-once_cell.spec b/rust-once_cell.spec
index 496ac7f..e10f5f0 100644
--- a/rust-once_cell.spec
+++ b/rust-once_cell.spec
@@ -1,11 +1,11 @@
-# Generated by rust2rpm 22
+# Generated by rust2rpm 23
 %bcond_without check
 %global debug_package %{nil}
 
 %global crate once_cell
 
 Name:           rust-once_cell
-Version:        1.15.0
+Version:        1.16.0
 Release:        %autorelease
 Summary:        Single assignment cells and lazy values
 
@@ -13,8 +13,6 @@ License:        MIT OR Apache-2.0
 URL:            https://crates.io/crates/once_cell
 Source:         %{crates_source}
 
-ExclusiveArch:  %{rust_arches}
-
 BuildRequires:  rust-packaging >= 21
 
 %global _description %{expand:
@@ -62,6 +60,54 @@ use the "alloc" feature of the "%{crate}" crate.
 %files       -n %{name}+alloc-devel
 %ghost %{crate_instdir}/Cargo.toml
 
+%package     -n %{name}+atomic-polyfill-devel
+Summary:        %{summary}
+BuildArch:      noarch
+
+%description -n %{name}+atomic-polyfill-devel %{_description}
+
+This package contains library source intended for building other packages which
+use the "atomic-polyfill" feature of the "%{crate}" crate.
+
+%files       -n %{name}+atomic-polyfill-devel
+%ghost %{crate_instdir}/Cargo.toml
+
+%package     -n %{name}+atomic_polyfill-devel
+Summary:        %{summary}
+BuildArch:      noarch
+
+%description -n %{name}+atomic_polyfill-devel %{_description}
+
+This package contains library source intended for building other packages which
+use the "atomic_polyfill" feature of the "%{crate}" crate.
+
+%files       -n %{name}+atomic_polyfill-devel
+%ghost %{crate_instdir}/Cargo.toml
+
+%package     -n %{name}+critical-section-devel
+Summary:        %{summary}
+BuildArch:      noarch
+
+%description -n %{name}+critical-section-devel %{_description}
+
+This package contains library source intended for building other packages which
+use the "critical-section" feature of the "%{crate}" crate.
+
+%files       -n %{name}+critical-section-devel
+%ghost %{crate_instdir}/Cargo.toml
+
+%package     -n %{name}+critical_section-devel
+Summary:        %{summary}
+BuildArch:      noarch
+
+%description -n %{name}+critical_section-devel %{_description}
+
+This package contains library source intended for building other packages which
+use the "critical_section" feature of the "%{crate}" crate.
+
+%files       -n %{name}+critical_section-devel
+%ghost %{crate_instdir}/Cargo.toml
+
 %package     -n %{name}+parking_lot-devel
 Summary:        %{summary}
 BuildArch:      noarch
diff --git a/rust2rpm.conf b/rust2rpm.conf
deleted file mode 100644
index 6593735..0000000
--- a/rust2rpm.conf
+++ /dev/null
@@ -1,3 +0,0 @@
-[DEFAULT]
-unwanted-features =
-  atomic-polyfill
diff --git a/sources b/sources
index 9faafbb..b31434f 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-SHA512 (once_cell-1.15.0.crate) = 934a7c3631e9ca4fa78d9577b6672ca0b2f926a8d6c3be9542b906c5968033446f98f76ae6f368a1a5b92ab9064c31a57d74ab6d2097108029a7ea951541ff7e
+SHA512 (once_cell-1.16.0.crate) = bc199570ee43bde9245a2c4637ae738e370ce9988635c8342349ceb6fb158f376247b69f9ec4ea0e6d76b934decdc77a524299ebde96c0a2c2d29d9501b9a568