You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-object/object-0.9.0-fix-metadata.diff

26 lines
629 B

--- object-0.9.0/Cargo.toml 1970-01-01T01:00:00+01:00
+++ object-0.9.0/Cargo.toml 2018-07-28T17:39:05.114833+02:00
@@ -23,13 +23,9 @@
optional = true
[dependencies.goblin]
-version = "0.0.15"
+version = "0.0.17"
features = ["endian_fd", "elf32", "elf64", "mach32", "mach64", "pe32", "pe64", "archive"]
default-features = false
-
-[dependencies.parity-wasm]
-version = "0.31.0"
-optional = true
[dependencies.scroll]
version = "0.9"
@@ -43,6 +39,5 @@
[features]
compression = ["flate2"]
-default = ["std", "compression", "wasm"]
+default = ["std", "compression"]
std = ["goblin/std"]
-wasm = ["std", "parity-wasm"]