You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-object/object-fix-metadata.diff

24 lines
590 B

--- object-0.19.0/Cargo.toml 2020-05-12T03:49:31+00:00
+++ object-0.19.0/Cargo.toml 2020-05-12T18:46:54.787770+00:00
@@ -46,9 +46,6 @@
version = "1.1"
optional = true
-[dependencies.wasmparser]
-version = "0.54"
-optional = true
[dev-dependencies.memmap]
version = "0.7"
@@ -59,9 +56,8 @@
elf = []
macho = []
pe = ["coff"]
-read = ["read_core", "coff", "elf", "macho", "pe", "wasm"]
+read = ["read_core", "coff", "elf", "macho", "pe"]
read_core = []
std = []
-wasm = ["wasmparser"]
write = ["write_core", "coff", "elf", "macho"]
write_core = ["crc32fast", "indexmap", "std"]