You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-object/object-fix-metadata.diff

26 lines
693 B

--- object-0.20.0/Cargo.toml 2020-06-15T05:48:59+00:00
+++ object-0.20.0/Cargo.toml 2020-06-15T23:11:31.787560+00:00
@@ -60,9 +60,6 @@
version = "1.1"
optional = true
-[dependencies.wasmparser]
-version = "0.57"
-optional = true
[dev-dependencies.memmap]
version = "0.7"
@@ -75,11 +72,10 @@
elf = []
macho = []
pe = ["coff"]
-read = ["read_core", "coff", "elf", "macho", "pe", "wasm", "unaligned"]
+read = ["read_core", "coff", "elf", "macho", "pe", "unaligned"]
read_core = []
rustc-dep-of-std = ["core", "compiler_builtins", "alloc"]
std = []
unaligned = []
-wasm = ["wasmparser"]
write = ["write_core", "coff", "elf", "macho"]
write_core = ["crc32fast", "indexmap", "std"]