You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
46 lines
1.1 KiB
46 lines
1.1 KiB
--- object-0.22.0/Cargo.toml 2020-10-27T03:03:10+00:00
|
|
+++ object-0.22.0/Cargo.toml 2020-11-07T14:10:27.632126+00:00
|
|
@@ -42,19 +42,6 @@
|
|
[[example]]
|
|
name = "objectmap"
|
|
required-features = ["read_core"]
|
|
-[dependencies.alloc]
|
|
-version = "1.0.0"
|
|
-optional = true
|
|
-package = "rustc-std-workspace-alloc"
|
|
-
|
|
-[dependencies.compiler_builtins]
|
|
-version = "0.1.2"
|
|
-optional = true
|
|
-
|
|
-[dependencies.core]
|
|
-version = "1.0.0"
|
|
-optional = true
|
|
-package = "rustc-std-workspace-core"
|
|
|
|
[dependencies.crc32fast]
|
|
version = "1.2"
|
|
@@ -68,9 +55,6 @@
|
|
version = "1.1"
|
|
optional = true
|
|
|
|
-[dependencies.wasmparser]
|
|
-version = "0.57"
|
|
-optional = true
|
|
[dev-dependencies.memmap]
|
|
version = "0.7"
|
|
|
|
@@ -84,11 +68,9 @@
|
|
elf = []
|
|
macho = []
|
|
pe = ["coff"]
|
|
-read = ["read_core", "archive", "coff", "elf", "macho", "pe", "wasm", "unaligned"]
|
|
+read = ["read_core", "archive", "coff", "elf", "macho", "pe", "unaligned"]
|
|
read_core = []
|
|
-rustc-dep-of-std = ["core", "compiler_builtins", "alloc"]
|
|
std = []
|
|
unaligned = []
|
|
-wasm = ["wasmparser"]
|
|
write = ["write_core", "coff", "elf", "macho"]
|
|
write_core = ["crc32fast", "indexmap", "std"]
|