You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-object/object-fix-metadata.diff

43 lines
998 B

--- object-0.24.0/Cargo.toml 1970-01-01T00:00:00+00:00
+++ object-0.24.0/Cargo.toml 2021-05-08T18:20:50.956784+00:00
@@ -46,19 +46,6 @@
[[example]]
name = "readobj"
required-features = ["read"]
-[dependencies.alloc]
-version = "1.0.0"
-optional = true
-package = "rustc-std-workspace-alloc"
-
-[dependencies.compiler_builtins]
-version = "0.1.2"
-optional = true
-
-[dependencies.core]
-version = "1.0.0"
-optional = true
-package = "rustc-std-workspace-core"
[dependencies.crc32fast]
version = "1.2"
@@ -72,9 +59,6 @@
version = "1.1"
optional = true
-[dependencies.wasmparser]
-version = "0.57"
-optional = true
[dev-dependencies.memmap]
version = "0.7"
@@ -90,9 +74,7 @@
pe = ["coff"]
read = ["read_core", "archive", "coff", "elf", "macho", "pe", "unaligned"]
read_core = []
-rustc-dep-of-std = ["core", "compiler_builtins", "alloc"]
std = []
unaligned = []
-wasm = ["wasmparser"]
write = ["write_core", "coff", "elf", "macho"]
write_core = ["crc32fast", "indexmap", "std"]