You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
49 lines
1.2 KiB
49 lines
1.2 KiB
--- object-0.26.2/Cargo.toml 1970-01-01T00:00:00+00:00
|
|
+++ object-0.26.2/Cargo.toml 2021-09-21T21:07:44.960855+00:00
|
|
@@ -45,19 +45,6 @@
|
|
[[example]]
|
|
name = "readobj"
|
|
required-features = ["read"]
|
|
-[dependencies.alloc]
|
|
-version = "1.0.0"
|
|
-optional = true
|
|
-package = "rustc-std-workspace-alloc"
|
|
-
|
|
-[dependencies.compiler_builtins]
|
|
-version = "0.1.2"
|
|
-optional = true
|
|
-
|
|
-[dependencies.core]
|
|
-version = "1.0.0"
|
|
-optional = true
|
|
-package = "rustc-std-workspace-core"
|
|
|
|
[dependencies.crc32fast]
|
|
version = "1.2"
|
|
@@ -75,14 +62,11 @@
|
|
version = "2.4.1"
|
|
default-features = false
|
|
|
|
-[dependencies.wasmparser]
|
|
-version = "0.57"
|
|
-optional = true
|
|
[dev-dependencies.memmap2]
|
|
version = "0.3"
|
|
|
|
[features]
|
|
-all = ["read", "write", "std", "compression", "wasm"]
|
|
+all = ["read", "write", "std", "compression"]
|
|
archive = []
|
|
cargo-all = []
|
|
coff = []
|
|
@@ -93,9 +77,7 @@
|
|
pe = ["coff"]
|
|
read = ["read_core", "archive", "coff", "elf", "macho", "pe", "unaligned"]
|
|
read_core = []
|
|
-rustc-dep-of-std = ["core", "compiler_builtins", "alloc", "memchr/rustc-dep-of-std"]
|
|
std = ["memchr/std"]
|
|
unaligned = []
|
|
-wasm = ["wasmparser"]
|
|
write = ["write_core", "coff", "elf", "macho"]
|
|
write_core = ["crc32fast", "indexmap", "std"]
|