Update to 0.9.0

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 7 years ago
parent 3c99a28089
commit f7df061616
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -1,2 +1,3 @@
/object-0.6.0.crate
/object-0.7.0.crate
/object-0.9.0.crate

@ -1,26 +0,0 @@
From dd038c59eae24707b37c6788aed6387d79f68ed6 Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
Date: Thu, 18 Jan 2018 09:28:39 +0100
Subject: [PATCH] deps: update goblin to 0.0.14
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
---
src/macho.rs | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/macho.rs b/src/macho.rs
index 1bcc4ab..e40a670 100644
--- a/src/macho.rs
+++ b/src/macho.rs
@@ -203,7 +203,7 @@ where
#[inline]
fn is_little_endian(&self) -> bool {
- self.macho.header.is_little_endian()
+ self.macho.little_endian
}
}
--
2.15.1

@ -1,11 +0,0 @@
--- object-0.7.0/Cargo.toml 1970-01-01T01:00:00+01:00
+++ object-0.7.0/Cargo.toml 2018-04-23T14:23:02.170797+02:00
@@ -19,7 +19,7 @@
license = "Apache-2.0/MIT"
repository = "https://github.com/gimli-rs/object"
[dependencies.goblin]
-version = "0.0.13"
+version = "0.0.15"
[dev-dependencies.memmap]
version = "0.6"

@ -0,0 +1,21 @@
--- object-0.9.0/Cargo.toml 1970-01-01T01:00:00+01:00
+++ object-0.9.0/Cargo.toml 2018-07-28T16:52:21.092836+02:00
@@ -27,10 +27,6 @@
features = ["endian_fd", "elf32", "elf64", "mach32", "mach64", "pe32", "pe64", "archive"]
default-features = false
-[dependencies.parity-wasm]
-version = "0.31.0"
-optional = true
-
[dependencies.scroll]
version = "0.9"
default-features = false
@@ -43,6 +39,5 @@
[features]
compression = ["flate2"]
-default = ["std", "compression", "wasm"]
+default = ["std", "compression"]
std = ["goblin/std"]
-wasm = ["std", "parity-wasm"]

@ -5,24 +5,25 @@
%global crate object
Name: rust-%{crate}
Version: 0.7.0
Release: 6%{?dist}
Summary: Unified interface for the target platform's object file format
Version: 0.9.0
Release: 1%{?dist}
Summary: Unified interface for parsing object file formats
License: ASL 2.0 or MIT
URL: https://crates.io/crates/object
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Bump goblin to 0.0.15, https://github.com/gimli-rs/object/pull/48
Patch0: object-0.7.0-fix-metadata.diff
# Make it work with goblin v0.0.14
Patch1: 0001-deps-update-goblin-to-0.0.14.patch
# * parity-wasm is not packaged yet
Patch0: object-0.9.0-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
# [dependencies]
BuildRequires: (crate(goblin) >= 0.0.15 with crate(goblin) < 0.0.16)
BuildRequires: (crate(flate2) >= 1.0.0 with crate(flate2) < 2.0.0)
BuildRequires: ((crate(goblin) >= 0.0.15 with crate(goblin) < 0.0.16) with crate(goblin/endian_fd) with crate(goblin/elf32) with crate(goblin/elf64) with crate(goblin/mach32) with crate(goblin/mach64) with crate(goblin/pe32) with crate(goblin/pe64) with crate(goblin/archive))
BuildRequires: (crate(scroll) >= 0.9.0 with crate(scroll) < 0.10.0)
BuildRequires: (crate(uuid) >= 0.6.0 with crate(uuid) < 0.7.0)
%if %{with check}
# [dev-dependencies]
BuildRequires: (crate(memmap) >= 0.6.0 with crate(memmap) < 0.7.0)
@ -36,7 +37,7 @@ Summary: %{summary}
BuildArch: noarch
%description devel
A unified interface for the target platform's object file format.
A unified interface for parsing object file formats.
This package contains library source intended for building other packages
which use %{crate} from crates.io.
@ -63,6 +64,9 @@ which use %{crate} from crates.io.
%exclude %{cargo_registry}/%{crate}-%{version}/coverage
%changelog
* Sat Jul 28 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.9.0-1
- Update to 0.9.0
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.0-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

@ -1 +1 @@
SHA512 (object-0.7.0.crate) = fe1a9435527df0b5df05e9f449f80ee1db4ed818d06c9fd16f19797d16ba8e003ed4a5b1b6d2e1e7768dabf8cb66ff6c532ac76667739cae1d19206e13e1feeb
SHA512 (object-0.9.0.crate) = f46143332b869cb6668cf2c7b8ac8a280accb3ca996cc13cbaf8e8a26d68cf4c2082473b63819aeb3b9954e6efe292d444176a8427fe77ec32bbd7f68a2db81f

Loading…
Cancel
Save