Update to version 0.29.0; Fixes RHBZ#2014821

epel9
Fabio Valentini 3 years ago
parent 2f66c3e2bf
commit f7b8d9a7b8
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -12,3 +12,4 @@
/object-0.24.0.crate
/object-0.26.2.crate
/object-0.27.1.crate
/object-0.29.0.crate

@ -1,6 +1,6 @@
--- object-0.27.1/Cargo.toml 1970-01-01T00:00:00+00:00
+++ object-0.27.1/Cargo.toml 2022-02-03T15:04:23.969609+00:00
@@ -51,18 +51,13 @@
--- object-0.29.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ object-0.29.0/Cargo.toml 2022-08-09T09:38:46.983845+00:00
@@ -68,17 +68,12 @@
version = "2.4.1"
default-features = false
@ -9,21 +9,28 @@
-optional = true
-
[features]
-all = ["read", "write", "std", "compression", "wasm"]
+all = ["read", "write", "std", "compression"]
all = [
"read",
"write",
"std",
"compression",
- "wasm",
]
archive = []
cargo-all = []
coff = []
compression = ["flate2", "std"]
default = ["read", "compression"]
-doc = ["read_core", "write_core", "std", "compression", "archive", "coff", "elf", "macho", "pe", "wasm"]
@@ -101,7 +96,6 @@
"elf",
"macho",
"pe",
- "wasm",
]
elf = []
macho = []
pe = ["coff"]
@@ -71,6 +66,5 @@
rustc-dep-of-std = ["core", "compiler_builtins", "alloc", "memchr/rustc-dep-of-std"]
@@ -124,7 +118,6 @@
]
std = ["memchr/std"]
unaligned = []
-wasm = ["wasmparser"]
write = ["write_core", "coff", "elf", "macho", "pe"]
write_core = ["crc32fast", "indexmap/std", "std"]
write = [
"write_std",
"coff",

@ -1,25 +1,24 @@
# Generated by rust2rpm 20
# Generated by rust2rpm 22
%bcond_without check
%global debug_package %{nil}
%global crate object
Name: rust-%{crate}
Version: 0.27.1
Name: rust-object
Version: 0.29.0
Release: %autorelease
Summary: Unified interface for reading and writing object file formats
# Upstream license specification: Apache-2.0/MIT
License: ASL 2.0 or MIT
License: Apache-2.0 OR MIT
URL: https://crates.io/crates/object
Source: %{crates_source}
# Initial patched metadata
# Manually created patch for downstream crate metadata changes
# * disable WASM support (wasmparser dependency is very outdated)
Patch0: object-fix-metadata.diff
Patch: object-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Unified interface for reading and writing object file formats.}
@ -36,9 +35,11 @@ This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE-APACHE LICENSE-MIT
%doc CHANGELOG.md README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -50,7 +51,7 @@ This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+all-devel
Summary: %{summary}
@ -62,7 +63,7 @@ This package contains library source intended for building other packages which
use the "all" feature of the "%{crate}" crate.
%files -n %{name}+all-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+archive-devel
Summary: %{summary}
@ -74,7 +75,7 @@ This package contains library source intended for building other packages which
use the "archive" feature of the "%{crate}" crate.
%files -n %{name}+archive-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+cargo-all-devel
Summary: %{summary}
@ -86,7 +87,7 @@ This package contains library source intended for building other packages which
use the "cargo-all" feature of the "%{crate}" crate.
%files -n %{name}+cargo-all-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+coff-devel
Summary: %{summary}
@ -98,7 +99,7 @@ This package contains library source intended for building other packages which
use the "coff" feature of the "%{crate}" crate.
%files -n %{name}+coff-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+compression-devel
Summary: %{summary}
@ -110,7 +111,7 @@ This package contains library source intended for building other packages which
use the "compression" feature of the "%{crate}" crate.
%files -n %{name}+compression-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+crc32fast-devel
Summary: %{summary}
@ -122,7 +123,19 @@ This package contains library source intended for building other packages which
use the "crc32fast" feature of the "%{crate}" crate.
%files -n %{name}+crc32fast-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+doc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+doc-devel %{_description}
This package contains library source intended for building other packages which
use the "doc" feature of the "%{crate}" crate.
%files -n %{name}+doc-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+elf-devel
Summary: %{summary}
@ -134,7 +147,7 @@ This package contains library source intended for building other packages which
use the "elf" feature of the "%{crate}" crate.
%files -n %{name}+elf-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+flate2-devel
Summary: %{summary}
@ -146,7 +159,19 @@ This package contains library source intended for building other packages which
use the "flate2" feature of the "%{crate}" crate.
%files -n %{name}+flate2-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+hashbrown-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+hashbrown-devel %{_description}
This package contains library source intended for building other packages which
use the "hashbrown" feature of the "%{crate}" crate.
%files -n %{name}+hashbrown-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+indexmap-devel
Summary: %{summary}
@ -158,7 +183,7 @@ This package contains library source intended for building other packages which
use the "indexmap" feature of the "%{crate}" crate.
%files -n %{name}+indexmap-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+macho-devel
Summary: %{summary}
@ -170,7 +195,7 @@ This package contains library source intended for building other packages which
use the "macho" feature of the "%{crate}" crate.
%files -n %{name}+macho-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+pe-devel
Summary: %{summary}
@ -182,7 +207,7 @@ This package contains library source intended for building other packages which
use the "pe" feature of the "%{crate}" crate.
%files -n %{name}+pe-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+read-devel
Summary: %{summary}
@ -194,7 +219,7 @@ This package contains library source intended for building other packages which
use the "read" feature of the "%{crate}" crate.
%files -n %{name}+read-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+read_core-devel
Summary: %{summary}
@ -206,7 +231,7 @@ This package contains library source intended for building other packages which
use the "read_core" feature of the "%{crate}" crate.
%files -n %{name}+read_core-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
@ -218,7 +243,7 @@ This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unaligned-devel
Summary: %{summary}
@ -230,7 +255,7 @@ This package contains library source intended for building other packages which
use the "unaligned" feature of the "%{crate}" crate.
%files -n %{name}+unaligned-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+write-devel
Summary: %{summary}
@ -242,7 +267,7 @@ This package contains library source intended for building other packages which
use the "write" feature of the "%{crate}" crate.
%files -n %{name}+write-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+write_core-devel
Summary: %{summary}
@ -254,7 +279,19 @@ This package contains library source intended for building other packages which
use the "write_core" feature of the "%{crate}" crate.
%files -n %{name}+write_core-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+write_std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+write_std-devel %{_description}
This package contains library source intended for building other packages which
use the "write_std" feature of the "%{crate}" crate.
%files -n %{name}+write_std-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
@ -271,7 +308,8 @@ use the "write_core" feature of the "%{crate}" crate.
%if %{with check}
%check
%cargo_test
# * skip tests that require files which are not included in published crates
%cargo_test -- -- --skip read::coff::coff_extended_relocations
%endif
%changelog

@ -1 +1 @@
SHA512 (object-0.27.1.crate) = 3f25b663fdbf9a38090c2b1cdc03ca40bead87fb83f99143e79a272dfa4f2fedc387a50d3412d42a53aab228bbcbc6967fdb5a0c8db0a8a3e3ae9cdcf1061589
SHA512 (object-0.29.0.crate) = fb69ed164b9d766b2eb268b3492134ba9ca6b4358eb61712773c44c5c0676ce04e3e0c749f947658ee1423dce5e11237f6b6c0320f2d32bd6979cae141273dc2

Loading…
Cancel
Save