commit
c38cf9228b
Binary file not shown.
@ -0,0 +1,36 @@
|
||||
--- object-0.30.3/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ object-0.30.3/Cargo.toml 2023-03-30T18:31:27.154876+00:00
|
||||
@@ -70,17 +70,12 @@
|
||||
version = "2.4.1"
|
||||
default-features = false
|
||||
|
||||
-[dependencies.wasmparser]
|
||||
-version = "0.57"
|
||||
-optional = true
|
||||
-
|
||||
[features]
|
||||
all = [
|
||||
"read",
|
||||
"write",
|
||||
"std",
|
||||
"compression",
|
||||
- "wasm",
|
||||
]
|
||||
archive = []
|
||||
cargo-all = []
|
||||
@@ -103,7 +98,6 @@
|
||||
"elf",
|
||||
"macho",
|
||||
"pe",
|
||||
- "wasm",
|
||||
]
|
||||
elf = []
|
||||
macho = []
|
||||
@@ -132,7 +126,6 @@
|
||||
"unstable",
|
||||
"xcoff",
|
||||
]
|
||||
-wasm = ["wasmparser"]
|
||||
write = [
|
||||
"write_std",
|
||||
"coff",
|
@ -0,0 +1,468 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.3.5)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 1;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 24
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate object
|
||||
|
||||
Name: rust-object
|
||||
Version: 0.30.3
|
||||
Release: %autorelease
|
||||
Summary: Unified interface for reading and writing object file formats
|
||||
|
||||
License: Apache-2.0 OR MIT
|
||||
URL: https://crates.io/crates/object
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * disable WASM support (wasmparser dependency is very outdated)
|
||||
Patch: object-fix-metadata.diff
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
A unified interface for reading and writing object file formats.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+all-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+all-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "all" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+all-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+archive-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+archive-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "archive" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+archive-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+cargo-all-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+cargo-all-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "cargo-all" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+cargo-all-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+coff-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+coff-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "coff" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+coff-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+compression-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+compression-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "compression" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+compression-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+crc32fast-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+crc32fast-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "crc32fast" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+crc32fast-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+doc-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+doc-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "doc" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+doc-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+elf-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+elf-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "elf" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+elf-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+flate2-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+flate2-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "flate2" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+flate2-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+hashbrown-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+hashbrown-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "hashbrown" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+hashbrown-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+indexmap-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+indexmap-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "indexmap" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+indexmap-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+macho-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+macho-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "macho" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+macho-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+pe-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+pe-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "pe" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+pe-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+read-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+read-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "read" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+read-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+read_core-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+read_core-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "read_core" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+read_core-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+std-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+std-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "std" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+std-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+unaligned-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+unaligned-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "unaligned" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+unaligned-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+unstable-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+unstable-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "unstable" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+unstable-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+unstable-all-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+unstable-all-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "unstable-all" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+unstable-all-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+write-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+write-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "write" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+write-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+write_core-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+write_core-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "write_core" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+write_core-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+write_std-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+write_std-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "write_std" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+write_std-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+xcoff-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+xcoff-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "xcoff" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+xcoff-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
# * skip tests that require files which are not included in published crates
|
||||
%cargo_test -- -- --skip read::coff::coff_extended_relocations
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Nov 20 2023 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.30.3-1
|
||||
- Rebuilt for MSVSphere 9.2
|
||||
|
||||
* Thu Mar 30 2023 Fabio Valentini <decathorpe@gmail.com> - 0.30.3-1
|
||||
- Update to version 0.30.3; Fixes RHBZ#2144698
|
||||
|
||||
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.29.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Tue Aug 09 2022 Fabio Valentini <decathorpe@gmail.com> - 0.29.0-1
|
||||
- Update to version 0.29.0; Fixes RHBZ#2014821
|
||||
|
||||
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.27.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Thu Feb 03 2022 Fabio Valentini <decathorpe@gmail.com> - 0.27.1-1
|
||||
- Update to version 0.27.1
|
||||
|
||||
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.26.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Tue Sep 21 2021 Fabio Valentini <decathorpe@gmail.com> - 0.26.2-1
|
||||
- Update to version 0.26.2; Fixes RHBZ#1966865
|
||||
|
||||
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.24.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Sat May 08 2021 Fabio Valentini <decathorpe@gmail.com> - 0.24.0-1
|
||||
- Update to version 0.24.0.
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.22.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Sat Nov 07 2020 Fabio Valentini <decathorpe@gmail.com> - 0.22.0-1
|
||||
- Update to version 0.22.0.
|
||||
- Fixes RHBZ#1868548
|
||||
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.20.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Mon Jun 15 2020 Josh Stone <jistone@redhat.com> - 0.20.0-1
|
||||
- Update to 0.20.0
|
||||
|
||||
* Tue May 12 2020 Josh Stone <jistone@redhat.com> - 0.19.0-1
|
||||
- Update to 0.19.0
|
||||
|
||||
* Tue May 05 2020 Josh Stone <jistone@redhat.com> - 0.18.0-1
|
||||
- Update to 0.18.0
|
||||
|
||||
* Wed Feb 26 2020 Josh Stone <jistone@redhat.com> - 0.17.0-2
|
||||
- Bump goblin to 0.2
|
||||
|
||||
* Wed Feb 19 2020 Josh Stone <jistone@redhat.com> - 0.17.0-1
|
||||
- Update to 0.17.0
|
||||
|
||||
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Tue May 07 15:33:29 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.12.0-1
|
||||
- Update to 0.12.0
|
||||
|
||||
* Sat Apr 20 17:45:43 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.11.0-4
|
||||
- Update goblin to 0.0.22
|
||||
|
||||
* Fri Apr 05 16:26:43 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.11.0-3
|
||||
- Run tests in infrastructure
|
||||
|
||||
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.11.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Tue Nov 27 2018 Josh Stone <jistone@redhat.com> - 0.11.0-1
|
||||
- Update to 0.11.0
|
||||
|
||||
* Tue Nov 13 2018 Josh Stone <jistone@redhat.com> - 0.10.0-2
|
||||
- Adapt to new packaging
|
||||
|
||||
* Tue Oct 02 2018 Josh Stone <jistone@redhat.com> - 0.10.0-1
|
||||
- Update to 0.10.0
|
||||
|
||||
* Sat Jul 28 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.9.0-2
|
||||
- Bump goblin to 0.0.17
|
||||
|
||||
* Sat Jul 28 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.9.0-1
|
||||
- Update to 0.9.0
|
||||
|
||||
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.0-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Mon Apr 23 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.0-5
|
||||
- Bump goblin to 0.0.15
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Jan 18 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.0-3
|
||||
- Bump goblin to 0.0.14
|
||||
|
||||
* Mon Jan 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.0-2
|
||||
- Rebuild for rust-packaging v5
|
||||
|
||||
* Mon Jan 01 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.0-1
|
||||
- Update to 0.7.0
|
||||
|
||||
* Sun Dec 03 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.0-1
|
||||
- Initial package
|
||||
|
Loading…
Reference in new issue