parent
d9a3056bad
commit
39a1697f31
@ -1,3 +1,4 @@
|
||||
/object-0.6.0.crate
|
||||
/object-0.7.0.crate
|
||||
/object-0.9.0.crate
|
||||
/object-0.10.0.crate
|
||||
|
@ -1,27 +0,0 @@
|
||||
From fddbb92505268aa4892180e159828976c98088dc Mon Sep 17 00:00:00 2001
|
||||
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
||||
Date: Sat, 28 Jul 2018 17:37:57 +0200
|
||||
Subject: [PATCH] deps: update goblin to 0.0.17
|
||||
|
||||
Fixes: https://github.com/gimli-rs/object/issues/62
|
||||
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
||||
---
|
||||
src/pe.rs | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/pe.rs b/src/pe.rs
|
||||
index dba3bfc..77e0aa4 100644
|
||||
--- a/src/pe.rs
|
||||
+++ b/src/pe.rs
|
||||
@@ -269,7 +269,7 @@ impl<'data, 'file> Iterator for PeSymbolIterator<'data, 'file> {
|
||||
kind: SymbolKind::Unknown,
|
||||
section_kind: Some(SectionKind::Unknown),
|
||||
global: true,
|
||||
- name: Some(export.name),
|
||||
+ name: export.name,
|
||||
address: export.rva as u64,
|
||||
size: 0,
|
||||
});
|
||||
--
|
||||
2.18.0
|
||||
|
@ -1,21 +1,17 @@
|
||||
--- object-0.9.0/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||
+++ object-0.9.0/Cargo.toml 2018-07-28T17:39:05.114833+02:00
|
||||
@@ -23,13 +23,9 @@
|
||||
optional = true
|
||||
|
||||
[dependencies.goblin]
|
||||
-version = "0.0.15"
|
||||
+version = "0.0.17"
|
||||
--- object-0.10.0/Cargo.toml 1969-12-31T16:00:00-08:00
|
||||
+++ object-0.10.0/Cargo.toml 2018-10-02T10:14:40.393495-07:00
|
||||
@@ -28,10 +28,6 @@
|
||||
features = ["endian_fd", "elf32", "elf64", "mach32", "mach64", "pe32", "pe64", "archive"]
|
||||
default-features = false
|
||||
-
|
||||
|
||||
-[dependencies.parity-wasm]
|
||||
-version = "0.31.0"
|
||||
-optional = true
|
||||
|
||||
-
|
||||
[dependencies.scroll]
|
||||
version = "0.9"
|
||||
@@ -43,6 +39,5 @@
|
||||
default-features = false
|
||||
@@ -44,6 +40,5 @@
|
||||
|
||||
[features]
|
||||
compression = ["flate2"]
|
@ -1 +1 @@
|
||||
SHA512 (object-0.9.0.crate) = f46143332b869cb6668cf2c7b8ac8a280accb3ca996cc13cbaf8e8a26d68cf4c2082473b63819aeb3b9954e6efe292d444176a8427fe77ec32bbd7f68a2db81f
|
||||
SHA512 (object-0.10.0.crate) = 0545d2d8e49b21d61b1acde09670db43c2832eaa8d857b89f05cf8f07d75f114d980f964b8f6b66a3877def89c0aed59abdcc4cdf58a1bf6afba36d00916ebc3
|
||||
|
Loading…
Reference in new issue