commit
80281454fc
Binary file not shown.
@ -0,0 +1,8 @@
|
||||
--- num_threads-0.1.6/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ num_threads-0.1.6/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
@@ -32,5 +32,3 @@
|
||||
|
||||
[dependencies]
|
||||
|
||||
-[target."cfg(any(target_os = \"macos\", target_os = \"ios\", target_os = \"freebsd\"))".dependencies.libc]
|
||||
-version = "0.2.107"
|
@ -0,0 +1,96 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.3.1)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 4;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 23
|
||||
# * tests are broken due to test runner changes in Rust 1.67+:
|
||||
# https://github.com/jhpratt/num_threads/issues/13
|
||||
%bcond_with check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate num_threads
|
||||
|
||||
Name: rust-num_threads
|
||||
Version: 0.1.6
|
||||
Release: %autorelease
|
||||
Summary: Determine the number of running threads for the current process
|
||||
|
||||
License: MIT OR Apache-2.0
|
||||
URL: https://crates.io/crates/num_threads
|
||||
Source: %{crates_source}
|
||||
# Automatically generated patch to strip foreign dependencies
|
||||
Patch: num_threads-fix-metadata-auto.diff
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Minimal library that determines the number of running threads for the current
|
||||
process.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-Apache
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.1.6-4
|
||||
- Rebuilt for MSVSphere 9.3
|
||||
|
||||
* Wed Feb 01 2023 Fabio Valentini <decathorpe@gmail.com> - 0.1.6-4
|
||||
- Disable tests which broke due to test runner changes in Rust 1.67+
|
||||
|
||||
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.6-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.6-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Tue May 31 2022 Fabio Valentini <decathorpe@gmail.com> - 0.1.6-1
|
||||
- Initial import (#2086091)
|
Loading…
Reference in new issue