You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-num_enum_derive/rust-num_enum_derive.spec

121 lines
3.1 KiB

# Generated by rust2rpm 24
# * tests can only be run in-tree
%bcond_with check
%global debug_package %{nil}
%global crate num_enum_derive
Name: rust-num_enum_derive
Version: 0.5.11
Release: %autorelease
Summary: Internal implementation details for num_enum
License: BSD-3-Clause OR MIT OR Apache-2.0
URL: https://crates.io/crates/num_enum_derive
Source: %{crates_source}
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Internal implementation details for ::num_enum (Procedural macros to
make inter-operation between primitives and enums easier).}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-BSD
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+complex-expressions-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+complex-expressions-devel %{_description}
This package contains library source intended for building other packages which
use the "complex-expressions" feature of the "%{crate}" crate.
%files -n %{name}+complex-expressions-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+external_doc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+external_doc-devel %{_description}
This package contains library source intended for building other packages which
use the "external_doc" feature of the "%{crate}" crate.
%files -n %{name}+external_doc-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+proc-macro-crate-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+proc-macro-crate-devel %{_description}
This package contains library source intended for building other packages which
use the "proc-macro-crate" feature of the "%{crate}" crate.
%files -n %{name}+proc-macro-crate-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog