You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
167 lines
4.6 KiB
167 lines
4.6 KiB
## START: Set by rpmautospec
|
|
## (rpmautospec version 0.3.0)
|
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
|
release_number = 3;
|
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
|
print(release_number + base_release_number - 1);
|
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
|
## END: Set by rpmautospec
|
|
|
|
# Generated by rust2rpm 18
|
|
%bcond_without check
|
|
%global debug_package %{nil}
|
|
|
|
%global crate num
|
|
|
|
Name: rust-%{crate}0.3
|
|
Version: 0.3.1
|
|
Release: %autorelease
|
|
Summary: Collection of numeric types and traits for Rust
|
|
|
|
# Upstream license specification: MIT OR Apache-2.0
|
|
License: MIT or ASL 2.0
|
|
URL: https://crates.io/crates/num
|
|
Source: %{crates_source}
|
|
|
|
ExclusiveArch: %{rust_arches}
|
|
%if %{__cargo_skip_build}
|
|
BuildArch: noarch
|
|
%endif
|
|
|
|
BuildRequires: rust-packaging
|
|
|
|
%global _description %{expand:
|
|
Collection of numeric types and traits for Rust, including bigint, complex,
|
|
rational, range iterators, generic integers, and more!.}
|
|
|
|
%description %{_description}
|
|
|
|
%package devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description devel %{_description}
|
|
|
|
This package contains library source intended for building other packages
|
|
which use "%{crate}" crate.
|
|
|
|
%files devel
|
|
%license LICENSE-MIT LICENSE-APACHE
|
|
%doc README.md RELEASES.md
|
|
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
|
|
|
%package -n %{name}+default-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+default-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages
|
|
which use "default" feature of "%{crate}" crate.
|
|
|
|
%files -n %{name}+default-devel
|
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
|
|
|
%package -n %{name}+alloc-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+alloc-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages
|
|
which use "alloc" feature of "%{crate}" crate.
|
|
|
|
%files -n %{name}+alloc-devel
|
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
|
|
|
%package -n %{name}+libm-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+libm-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages
|
|
which use "libm" feature of "%{crate}" crate.
|
|
|
|
%files -n %{name}+libm-devel
|
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
|
|
|
%package -n %{name}+num-bigint-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+num-bigint-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages
|
|
which use "num-bigint" feature of "%{crate}" crate.
|
|
|
|
%files -n %{name}+num-bigint-devel
|
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
|
|
|
%package -n %{name}+rand-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+rand-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages
|
|
which use "rand" feature of "%{crate}" crate.
|
|
|
|
%files -n %{name}+rand-devel
|
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
|
|
|
%package -n %{name}+serde-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+serde-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages
|
|
which use "serde" feature of "%{crate}" crate.
|
|
|
|
%files -n %{name}+serde-devel
|
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
|
|
|
%package -n %{name}+std-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+std-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages
|
|
which use "std" feature of "%{crate}" crate.
|
|
|
|
%files -n %{name}+std-devel
|
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
|
%cargo_prep
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires
|
|
|
|
%build
|
|
%cargo_build
|
|
|
|
%install
|
|
%cargo_install
|
|
|
|
%if %{with check}
|
|
%check
|
|
%cargo_test
|
|
%endif
|
|
|
|
%changelog
|
|
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.3.1-3
|
|
- Rebuilt for MSVSphere 9.3
|
|
|
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> 0.3.1-3
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
|
|
|
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> 0.3.1-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
|
|
|
* Thu Aug 05 2021 Fabio Valentini <decathorpe@gmail.com> 0.3.1-1
|
|
- Initial import (num 0.3 compat package)
|