fix broken feature subpackages

epel10
Fabio Valentini 3 years ago
parent dfa6f7935f
commit 0b540f498c
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

@ -1,6 +1,6 @@
--- num-bigint-dig-0.7.0/Cargo.toml.orig 2022-02-13 00:56:51.899738425 +0000
+++ num-bigint-dig-0.7.0/Cargo.toml 2022-02-13 00:57:36.881015133 +0000
@@ -85,12 +85,8 @@
--- num-bigint-dig-0.7.0/Cargo.toml 2021-03-09T13:33:58+00:00
+++ num-bigint-dig-0.7.0/Cargo.toml 2022-03-14T15:54:56.726640+00:00
@@ -85,12 +85,11 @@
[dev-dependencies.serde_test]
version = "1.0"
[build-dependencies.autocfg]
@ -8,10 +8,9 @@
+version = "1.0.0"
[features]
-default = ["std", "i128", "u64_digit"]
+default = ["i128"]
default = ["std", "i128", "u64_digit"]
i128 = ["num-integer/i128", "num-traits/i128"]
-nightly = []
-prime = ["rand/std_rng"]
-std = ["num-integer/std", "num-traits/std", "smallvec/write", "rand/std", "serde/std"]
-u64_digit = []
prime = ["rand/std_rng"]
std = ["num-integer/std", "num-traits/std", "smallvec/write", "rand/std", "serde/std"]
u64_digit = []

@ -1,4 +1,4 @@
# Generated by rust2rpm 20
# Generated by rust2rpm 21
%bcond_without check
%global debug_package %{nil}
@ -6,7 +6,7 @@
Name: rust-%{crate}
Version: 0.7.0
Release: 1%{?dist}
Release: 2%{?dist}
Summary: Big integer implementation for Rust
# Upstream license specification: MIT/Apache-2.0
@ -20,7 +20,7 @@ Patch0: num-bigint-dig-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Big integer implementation for Rust.}
@ -37,9 +37,11 @@ This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE-APACHE LICENSE-MIT
%doc README.md RELEASES.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%doc %{crate_instdir}/RELEASES.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -51,7 +53,7 @@ This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+i128-devel
Summary: %{summary}
@ -63,7 +65,7 @@ This package contains library source intended for building other packages which
use the "i128" feature of the "%{crate}" crate.
%files -n %{name}+i128-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+prime-devel
Summary: %{summary}
@ -75,7 +77,7 @@ This package contains library source intended for building other packages which
use the "prime" feature of the "%{crate}" crate.
%files -n %{name}+prime-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rand-devel
Summary: %{summary}
@ -87,7 +89,7 @@ This package contains library source intended for building other packages which
use the "rand" feature of the "%{crate}" crate.
%files -n %{name}+rand-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
@ -99,7 +101,7 @@ This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
@ -111,7 +113,7 @@ This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+u64_digit-devel
Summary: %{summary}
@ -123,7 +125,7 @@ This package contains library source intended for building other packages which
use the "u64_digit" feature of the "%{crate}" crate.
%files -n %{name}+u64_digit-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+zeroize-devel
Summary: %{summary}
@ -135,7 +137,7 @@ This package contains library source intended for building other packages which
use the "zeroize" feature of the "%{crate}" crate.
%files -n %{name}+zeroize-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
@ -156,6 +158,9 @@ use the "zeroize" feature of the "%{crate}" crate.
%endif
%changelog
* Mon Mar 14 2022 Fabio Valentini <decathorpe@gmail.com> - 0.7.0-2
- Fix broken feature subpackages.
* Sun Feb 13 2022 Peter Robinson <pbrobinson@fedoraproject.org> - 0.7.0-1
- Update to 0.7.0

Loading…
Cancel
Save