You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-notify5/SOURCES/notify-fix-metadata-auto.diff

52 lines
1.4 KiB

--- notify-5.2.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ notify-5.2.0/Cargo.toml 2023-12-01T23:55:44.824159+00:00
@@ -68,20 +68,12 @@
"macos_fsevent",
"crossbeam-channel",
]
-macos_fsevent = ["fsevent-sys"]
+macos_fsevent = []
macos_kqueue = [
- "kqueue",
"mio",
]
manual_tests = []
timing_tests = []
-
-[target."cfg(any(target_os=\"freebsd\", target_os=\"openbsd\", target_os = \"netbsd\", target_os = \"dragonflybsd\"))".dependencies.kqueue]
-version = "^1.0.4"
-
-[target."cfg(any(target_os=\"freebsd\", target_os=\"openbsd\", target_os = \"netbsd\", target_os = \"dragonflybsd\"))".dependencies.mio]
-version = "0.8"
-features = ["os-ext"]
[target."cfg(any(target_os=\"linux\", target_os=\"android\"))".dependencies.inotify]
version = "0.9"
@@ -91,26 +83,3 @@
version = "0.8"
features = ["os-ext"]
-[target."cfg(target_os=\"macos\")".dependencies.fsevent-sys]
-version = "4"
-optional = true
-
-[target."cfg(target_os=\"macos\")".dependencies.kqueue]
-version = "1.0"
-optional = true
-
-[target."cfg(target_os=\"macos\")".dependencies.mio]
-version = "0.8"
-features = ["os-ext"]
-optional = true
-
-[target."cfg(windows)".dependencies.windows-sys]
-version = "0.45.0"
-features = [
- "Win32_System_Threading",
- "Win32_Foundation",
- "Win32_Storage_FileSystem",
- "Win32_Security",
- "Win32_System_WindowsProgramming",
- "Win32_System_IO",
-]