Initial import (#2103477)
parent
fd3d4ff129
commit
1a466ba27d
@ -0,0 +1 @@
|
||||
/normpath-0.3.2.crate
|
@ -0,0 +1,9 @@
|
||||
--- normpath-0.3.2/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ normpath-0.3.2/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
@@ -41,6 +41,3 @@
|
||||
version = "3.1"
|
||||
[target."cfg(not(windows))".dev-dependencies.libc]
|
||||
version = "0.2"
|
||||
-[target."cfg(windows)".dependencies.winapi]
|
||||
-version = "0.3"
|
||||
-features = ["fileapi"]
|
@ -0,0 +1,85 @@
|
||||
# Generated by rust2rpm 23
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate normpath
|
||||
|
||||
Name: rust-normpath
|
||||
Version: 0.3.2
|
||||
Release: %autorelease
|
||||
Summary: More reliable path manipulation
|
||||
|
||||
License: MIT OR Apache-2.0
|
||||
URL: https://crates.io/crates/normpath
|
||||
Source: %{crates_source}
|
||||
# Automatically generated patch to strip foreign dependencies
|
||||
Patch: normpath-fix-metadata-auto.diff
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
More reliable path manipulation.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/COPYRIGHT
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%license %{crate_instdir}/LICENSE-THIRD-PARTY
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+serde-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+serde-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "serde" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+serde-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
@ -0,0 +1,3 @@
|
||||
[DEFAULT]
|
||||
unwanted-features =
|
||||
print_bytes
|
Loading…
Reference in new issue