You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-nom5/rust-nom5.spec

171 lines
4.5 KiB

# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate nom
Name: rust-nom5
Version: 5.1.3
Release: %autorelease
Summary: Byte-oriented, zero-copy, parser combinators library
License: MIT
URL: https://crates.io/crates/nom
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop benchmarks and examples not shipped with the crate
# * drop criterion (too old) and jemallocator (not packaged) dev-dependencies
Patch: nom-fix-metadata.diff
BuildRequires: rust-packaging >= 21
%global _description %{expand:
A byte-oriented, zero-copy, parser combinators library.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+alloc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages which
use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+lazy_static-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+lazy_static-devel %{_description}
This package contains library source intended for building other packages which
use the "lazy_static" feature of the "%{crate}" crate.
%files -n %{name}+lazy_static-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+lexical-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+lexical-devel %{_description}
This package contains library source intended for building other packages which
use the "lexical" feature of the "%{crate}" crate.
%files -n %{name}+lexical-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+lexical-core-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+lexical-core-devel %{_description}
This package contains library source intended for building other packages which
use the "lexical-core" feature of the "%{crate}" crate.
%files -n %{name}+lexical-core-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+regex-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+regex-devel %{_description}
This package contains library source intended for building other packages which
use the "regex" feature of the "%{crate}" crate.
%files -n %{name}+regex-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+regexp-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+regexp-devel %{_description}
This package contains library source intended for building other packages which
use the "regexp" feature of the "%{crate}" crate.
%files -n %{name}+regexp-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+regexp_macros-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+regexp_macros-devel %{_description}
This package contains library source intended for building other packages which
use the "regexp_macros" feature of the "%{crate}" crate.
%files -n %{name}+regexp_macros-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
# * skip test that relies on exact size of a struct that fails with recent Rust
%cargo_test -- -- --skip internal::tests::size_test
%endif
%changelog
%autochangelog