Update to version 5.1.3

epel9
Fabio Valentini 2 years ago
parent 3a887376c7
commit 940608519e
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -2,3 +2,4 @@
/*.src.rpm
/nom-5.1.2.crate
/nom-5.1.3.crate

@ -1,10 +1,9 @@
--- nom-5.1.2/Cargo.toml 2020-06-12T09:23:25+00:00
+++ nom-5.1.2/Cargo.toml 2021-01-25T15:53:41.902083+00:00
@@ -34,21 +34,6 @@
--- nom-5.1.3/Cargo.toml 1970-01-01T00:00:01+00:00
+++ nom-5.1.3/Cargo.toml 2023-05-18T15:25:43.490321+00:00
@@ -59,21 +59,6 @@
[lib]
bench = false
-
-[[example]]
-name = "json"
-path = "examples/json.rs"
@ -19,10 +18,11 @@
-name = "string"
-path = "examples/string.rs"
-required-features = ["alloc"]
-
[[test]]
name = "arithmetic"
@@ -107,35 +92,6 @@
@@ -134,36 +119,6 @@
[[test]]
name = "test1"
@ -55,21 +55,22 @@
-name = "json"
-path = "benches/json.rs"
-harness = false
-
[dependencies.lazy_static]
version = "^1.0"
optional = true
@@ -151,14 +107,10 @@
[dependencies.regex]
@@ -180,14 +135,8 @@
version = "^1.0"
optional = true
-[dev-dependencies.criterion]
-version = "0.2"
-
[dev-dependencies.doc-comment]
version = "0.3"
-
-[dev-dependencies.jemallocator]
-version = "^0.1"
[build-dependencies.version_check]
version = "0.9"

@ -1,34 +1,26 @@
# Generated by rust2rpm 16
# rustdoc fails to compile some doctests on aarch64
# https://bugzilla.redhat.com/show_bug.cgi?id=1902663
%bcond_with check
# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate nom
Name: rust-%{crate}5
Version: 5.1.2
Name: rust-nom5
Version: 5.1.3
Release: %autorelease
Summary: Byte-oriented, zero-copy, parser combinators library
# Upstream license specification: MIT
License: MIT
URL: https://crates.io/crates/nom
Source: %{crates_source}
# Initial patched metadata
# Manually created patch for downstream crate metadata changes
# * drop benchmarks and examples not shipped with the crate
# * drop criterion (too old) and jemallocator (not packaged) dev-dependencies
Patch0: nom-fix-metadata.diff
Patch: nom-fix-metadata.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Byte-oriented, zero-copy, parser combinators library.}
A byte-oriented, zero-copy, parser combinators library.}
%description %{_description}
@ -38,13 +30,14 @@ BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE
%doc README.md CHANGELOG.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -52,11 +45,11 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+alloc-devel
Summary: %{summary}
@ -64,11 +57,11 @@ BuildArch: noarch
%description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages
which use "alloc" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+lazy_static-devel
Summary: %{summary}
@ -76,11 +69,11 @@ BuildArch: noarch
%description -n %{name}+lazy_static-devel %{_description}
This package contains library source intended for building other packages
which use "lazy_static" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "lazy_static" feature of the "%{crate}" crate.
%files -n %{name}+lazy_static-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+lexical-devel
Summary: %{summary}
@ -88,11 +81,11 @@ BuildArch: noarch
%description -n %{name}+lexical-devel %{_description}
This package contains library source intended for building other packages
which use "lexical" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "lexical" feature of the "%{crate}" crate.
%files -n %{name}+lexical-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+lexical-core-devel
Summary: %{summary}
@ -100,11 +93,11 @@ BuildArch: noarch
%description -n %{name}+lexical-core-devel %{_description}
This package contains library source intended for building other packages
which use "lexical-core" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "lexical-core" feature of the "%{crate}" crate.
%files -n %{name}+lexical-core-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+regex-devel
Summary: %{summary}
@ -112,11 +105,11 @@ BuildArch: noarch
%description -n %{name}+regex-devel %{_description}
This package contains library source intended for building other packages
which use "regex" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "regex" feature of the "%{crate}" crate.
%files -n %{name}+regex-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+regexp-devel
Summary: %{summary}
@ -124,11 +117,11 @@ BuildArch: noarch
%description -n %{name}+regexp-devel %{_description}
This package contains library source intended for building other packages
which use "regexp" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "regexp" feature of the "%{crate}" crate.
%files -n %{name}+regexp-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+regexp_macros-devel
Summary: %{summary}
@ -136,11 +129,11 @@ BuildArch: noarch
%description -n %{name}+regexp_macros-devel %{_description}
This package contains library source intended for building other packages
which use "regexp_macros" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "regexp_macros" feature of the "%{crate}" crate.
%files -n %{name}+regexp_macros-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
@ -148,11 +141,11 @@ BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages
which use "std" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
@ -169,7 +162,8 @@ which use "std" feature of "%{crate}" crate.
%if %{with check}
%check
%cargo_test
# * skip test that relies on exact size of a struct that fails with recent Rust
%cargo_test -- -- --skip internal::tests::size_test
%endif
%changelog

@ -1 +1 @@
SHA512 (nom-5.1.2.crate) = 53b8ddab62475588efae46c78b5fd086a14c0fa505c84e625fbedd6dc74d4ac047e9fbed7312b797f126e9ca1f056458d8ffe0ab13f0117de685ef8b43f86aca
SHA512 (nom-5.1.3.crate) = a0ecedc809a64c22280ca305b9dfdd54d06e8f080cbf443ccaa2e688666a1b2bddf7e9f8057e7f6f02cdb69ca478829d9fe4d6d0cb916903d050af3a7a0c911b

Loading…
Cancel
Save