You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-nix0.22/rust-nix0.22.spec

77 lines
1.8 KiB

# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate nix
Name: rust-nix0.22
Version: 0.22.3
Release: %autorelease
Summary: Rust friendly bindings to *nix APIs
License: MIT
URL: https://crates.io/crates/nix
Source: %{crates_source}
# Automatically generated patch to strip foreign dependencies
Patch: nix-fix-metadata-auto.diff
# * upstream patch to fix doctests with Rust 1.62+
Patch: https://github.com/nix-rust/nix/commit/0ac338b.patch
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Rust friendly bindings to *nix APIs.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/CONTRIBUTING.md
%doc %{crate_instdir}/CONVENTIONS.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
# * skip tests that hang or fail in the build environment
%cargo_test -- -- --skip sys::test_socket::test_af_alg_aead -- skip sys::test_socket::test_vsock
%endif
%changelog
%autochangelog