parent
c1abeffa43
commit
e16ad6e8fa
@ -1,46 +0,0 @@
|
||||
From 0ac338b74445bf55ffd70d6bc85f4339d151f6fc Mon Sep 17 00:00:00 2001
|
||||
From: Alex Rawson <ajzecrom@gmail.com>
|
||||
Date: Tue, 31 May 2022 17:51:45 -0500
|
||||
Subject: [PATCH] Ignore doctests for unexported macros
|
||||
|
||||
Due to rust-lang/rust#97030, cargo test will fail to doctest macros
|
||||
unless they are exported, breaking the examples for libc_bitflags! and
|
||||
libc_enum!.
|
||||
|
||||
Adds `ignore` to the examples for these macros to stop tests from
|
||||
failing.
|
||||
---
|
||||
src/macros.rs | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/src/macros.rs b/src/macros.rs
|
||||
index 018534fa67..99e0de8866 100644
|
||||
--- a/src/macros.rs
|
||||
+++ b/src/macros.rs
|
||||
@@ -19,7 +19,7 @@ macro_rules! feature {
|
||||
/// The `libc` crate must be in scope with the name `libc`.
|
||||
///
|
||||
/// # Example
|
||||
-/// ```
|
||||
+/// ```ignore
|
||||
/// libc_bitflags!{
|
||||
/// pub struct ProtFlags: libc::c_int {
|
||||
/// PROT_NONE;
|
||||
@@ -39,7 +39,7 @@ macro_rules! feature {
|
||||
/// various flags have different types, so we cast the broken ones to the right
|
||||
/// type.
|
||||
///
|
||||
-/// ```
|
||||
+/// ```ignore
|
||||
/// libc_bitflags!{
|
||||
/// pub struct SaFlags: libc::c_ulong {
|
||||
/// SA_NOCLDSTOP as libc::c_ulong;
|
||||
@@ -80,7 +80,7 @@ macro_rules! libc_bitflags {
|
||||
/// The `libc` crate must be in scope with the name `libc`.
|
||||
///
|
||||
/// # Example
|
||||
-/// ```
|
||||
+/// ```ignore
|
||||
/// libc_enum!{
|
||||
/// pub enum ProtFlags {
|
||||
/// PROT_NONE,
|
@ -0,0 +1,8 @@
|
||||
--- nix-0.24.2/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ nix-0.24.2/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
@@ -178,5 +178,3 @@
|
||||
version = "0.6.3"
|
||||
optional = true
|
||||
|
||||
-[target."cfg(target_os = \"freebsd\")".dev-dependencies.sysctl]
|
||||
-version = "0.1"
|
@ -1,9 +0,0 @@
|
||||
--- nix-0.24.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ nix-0.24.1/Cargo.toml 2022-05-25T11:22:24.524217+00:00
|
||||
@@ -177,6 +177,3 @@
|
||||
[target."cfg(not(target_os = \"redox\"))".dependencies.memoffset]
|
||||
version = "0.6.3"
|
||||
optional = true
|
||||
-
|
||||
-[target."cfg(target_os = \"freebsd\")".dev-dependencies.sysctl]
|
||||
-version = "0.1"
|
@ -1 +1 @@
|
||||
SHA512 (nix-0.24.1.crate) = eea2346477b5acbcc7c74fc0d3f99e35bc85f8195563599423cd838f258c388561e82feb66e9793528f55eea2cb015e899a335d6da82ca0c1b8acdff1b53efaa
|
||||
SHA512 (nix-0.24.2.crate) = 9502f899868466165d898b1dee676188e9761cbf7ad7be21e231d6d5c993f109b48edf06b659f547712ccec2d648dcdb689626845ecce22965aad2dfd7ed75ff
|
||||
|
Loading…
Reference in new issue