Update to version 0.24.1; Fixes RHBZ#2077320

epel9
Fabio Valentini 3 years ago
parent 5f373b4732
commit d6581ae208
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -14,3 +14,4 @@
/nix-0.22.1.crate
/nix-0.22.2.crate
/nix-0.23.1.crate
/nix-0.24.1.crate

@ -1,10 +1,9 @@
--- nix-0.23.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ nix-0.23.1/Cargo.toml 2022-01-11T11:19:42.208257+00:00
@@ -77,7 +77,3 @@
version = "0.5.1"
--- nix-0.24.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ nix-0.24.1/Cargo.toml 2022-05-25T11:22:24.524217+00:00
@@ -177,6 +177,3 @@
[target."cfg(not(target_os = \"redox\"))".dependencies.memoffset]
version = "0.6.3"
-[target."cfg(target_os = \"dragonfly\")".build-dependencies.cc]
-version = "1"
optional = true
-
-[target."cfg(target_os = \"freebsd\")".dev-dependencies.sysctl]
-version = "0.1"

@ -1,11 +1,11 @@
# Generated by rust2rpm 20
# Generated by rust2rpm 21
%bcond_without check
%global debug_package %{nil}
%global crate nix
Name: rust-%{crate}
Version: 0.23.1
Version: 0.24.1
Release: %autorelease
Summary: Rust friendly bindings to *nix APIs
@ -14,12 +14,12 @@ License: MIT
URL: https://crates.io/crates/nix
Source: %{crates_source}
# Initial patched metadata
# * drop DragonflyBSD/FreeBSD-specific dependencies
# * drop FreeBSD-specific dependencies
Patch0: nix-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Rust friendly bindings to *nix APIs.}
@ -36,9 +36,10 @@ This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE
%doc CHANGELOG.md README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -50,7 +51,403 @@ This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+acct-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+acct-devel %{_description}
This package contains library source intended for building other packages which
use the "acct" feature of the "%{crate}" crate.
%files -n %{name}+acct-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+aio-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+aio-devel %{_description}
This package contains library source intended for building other packages which
use the "aio" feature of the "%{crate}" crate.
%files -n %{name}+aio-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dir-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+dir-devel %{_description}
This package contains library source intended for building other packages which
use the "dir" feature of the "%{crate}" crate.
%files -n %{name}+dir-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+env-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+env-devel %{_description}
This package contains library source intended for building other packages which
use the "env" feature of the "%{crate}" crate.
%files -n %{name}+env-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+event-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+event-devel %{_description}
This package contains library source intended for building other packages which
use the "event" feature of the "%{crate}" crate.
%files -n %{name}+event-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+feature-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+feature-devel %{_description}
This package contains library source intended for building other packages which
use the "feature" feature of the "%{crate}" crate.
%files -n %{name}+feature-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+fs-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+fs-devel %{_description}
This package contains library source intended for building other packages which
use the "fs" feature of the "%{crate}" crate.
%files -n %{name}+fs-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+hostname-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+hostname-devel %{_description}
This package contains library source intended for building other packages which
use the "hostname" feature of the "%{crate}" crate.
%files -n %{name}+hostname-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+inotify-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+inotify-devel %{_description}
This package contains library source intended for building other packages which
use the "inotify" feature of the "%{crate}" crate.
%files -n %{name}+inotify-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ioctl-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+ioctl-devel %{_description}
This package contains library source intended for building other packages which
use the "ioctl" feature of the "%{crate}" crate.
%files -n %{name}+ioctl-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+kmod-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+kmod-devel %{_description}
This package contains library source intended for building other packages which
use the "kmod" feature of the "%{crate}" crate.
%files -n %{name}+kmod-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+memoffset-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+memoffset-devel %{_description}
This package contains library source intended for building other packages which
use the "memoffset" feature of the "%{crate}" crate.
%files -n %{name}+memoffset-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+mman-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+mman-devel %{_description}
This package contains library source intended for building other packages which
use the "mman" feature of the "%{crate}" crate.
%files -n %{name}+mman-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+mount-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+mount-devel %{_description}
This package contains library source intended for building other packages which
use the "mount" feature of the "%{crate}" crate.
%files -n %{name}+mount-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+mqueue-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+mqueue-devel %{_description}
This package contains library source intended for building other packages which
use the "mqueue" feature of the "%{crate}" crate.
%files -n %{name}+mqueue-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+net-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+net-devel %{_description}
This package contains library source intended for building other packages which
use the "net" feature of the "%{crate}" crate.
%files -n %{name}+net-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+personality-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+personality-devel %{_description}
This package contains library source intended for building other packages which
use the "personality" feature of the "%{crate}" crate.
%files -n %{name}+personality-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+poll-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+poll-devel %{_description}
This package contains library source intended for building other packages which
use the "poll" feature of the "%{crate}" crate.
%files -n %{name}+poll-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+process-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+process-devel %{_description}
This package contains library source intended for building other packages which
use the "process" feature of the "%{crate}" crate.
%files -n %{name}+process-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+pthread-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+pthread-devel %{_description}
This package contains library source intended for building other packages which
use the "pthread" feature of the "%{crate}" crate.
%files -n %{name}+pthread-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ptrace-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+ptrace-devel %{_description}
This package contains library source intended for building other packages which
use the "ptrace" feature of the "%{crate}" crate.
%files -n %{name}+ptrace-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+quota-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+quota-devel %{_description}
This package contains library source intended for building other packages which
use the "quota" feature of the "%{crate}" crate.
%files -n %{name}+quota-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+reboot-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+reboot-devel %{_description}
This package contains library source intended for building other packages which
use the "reboot" feature of the "%{crate}" crate.
%files -n %{name}+reboot-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+resource-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+resource-devel %{_description}
This package contains library source intended for building other packages which
use the "resource" feature of the "%{crate}" crate.
%files -n %{name}+resource-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+sched-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+sched-devel %{_description}
This package contains library source intended for building other packages which
use the "sched" feature of the "%{crate}" crate.
%files -n %{name}+sched-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+signal-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+signal-devel %{_description}
This package contains library source intended for building other packages which
use the "signal" feature of the "%{crate}" crate.
%files -n %{name}+signal-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+socket-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+socket-devel %{_description}
This package contains library source intended for building other packages which
use the "socket" feature of the "%{crate}" crate.
%files -n %{name}+socket-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+term-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+term-devel %{_description}
This package contains library source intended for building other packages which
use the "term" feature of the "%{crate}" crate.
%files -n %{name}+term-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+time-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+time-devel %{_description}
This package contains library source intended for building other packages which
use the "time" feature of the "%{crate}" crate.
%files -n %{name}+time-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ucontext-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+ucontext-devel %{_description}
This package contains library source intended for building other packages which
use the "ucontext" feature of the "%{crate}" crate.
%files -n %{name}+ucontext-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+uio-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+uio-devel %{_description}
This package contains library source intended for building other packages which
use the "uio" feature of the "%{crate}" crate.
%files -n %{name}+uio-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+user-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+user-devel %{_description}
This package contains library source intended for building other packages which
use the "user" feature of the "%{crate}" crate.
%files -n %{name}+user-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+zerocopy-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+zerocopy-devel %{_description}
This package contains library source intended for building other packages which
use the "zerocopy" feature of the "%{crate}" crate.
%files -n %{name}+zerocopy-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1

@ -1 +1 @@
SHA512 (nix-0.23.1.crate) = 23431030b094ebb027200d8cdc05d0ac1730fbb86ee088795a2314f1ba19b76ed5f24373c1aba8125575bf69f8e7d4d9c08344b9cb49a4ae3d8f7987b5f4e6b6
SHA512 (nix-0.24.1.crate) = eea2346477b5acbcc7c74fc0d3f99e35bc85f8195563599423cd838f258c388561e82feb66e9793528f55eea2cb015e899a335d6da82ca0c1b8acdff1b53efaa

Loading…
Cancel
Save