parent
c0db462214
commit
768ee57091
@ -0,0 +1,55 @@
|
||||
From b3ca1a7dd13b1ffbd768a5677b8d12346f6bf07c Mon Sep 17 00:00:00 2001
|
||||
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
||||
Date: Thu, 10 May 2018 11:45:33 +0200
|
||||
Subject: [PATCH] deps: update tempfile to 3
|
||||
|
||||
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
||||
---
|
||||
src/unistd.rs | 12 ++++++------
|
||||
1 file changed, 6 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/src/unistd.rs b/src/unistd.rs
|
||||
index 8022aa0..756a4d6 100644
|
||||
--- a/src/unistd.rs
|
||||
+++ b/src/unistd.rs
|
||||
@@ -421,15 +421,15 @@ pub fn fchdir(dirfd: RawFd) -> Result<()> {
|
||||
/// # Example
|
||||
///
|
||||
/// ```rust
|
||||
-/// extern crate tempdir;
|
||||
+/// extern crate tempfile;
|
||||
/// extern crate nix;
|
||||
///
|
||||
/// use nix::unistd;
|
||||
/// use nix::sys::stat;
|
||||
-/// use tempdir::TempDir;
|
||||
+/// use tempfile::TempDir;
|
||||
///
|
||||
/// fn main() {
|
||||
-/// let tmp_dir1 = TempDir::new("test_mkdir").unwrap();
|
||||
+/// let tmp_dir1 = TempDir::new().unwrap();
|
||||
/// let tmp_dir2 = tmp_dir1.path().join("new_dir");
|
||||
///
|
||||
/// // create new directory and give read, write and execute rights to the owner
|
||||
@@ -464,15 +464,15 @@ pub fn mkdir<P: ?Sized + NixPath>(path: &P, mode: Mode) -> Result<()> {
|
||||
/// # Example
|
||||
///
|
||||
/// ```rust
|
||||
-/// extern crate tempdir;
|
||||
+/// extern crate tempfile;
|
||||
/// extern crate nix;
|
||||
///
|
||||
/// use nix::unistd;
|
||||
/// use nix::sys::stat;
|
||||
-/// use tempdir::TempDir;
|
||||
+/// use tempfile::TempDir;
|
||||
///
|
||||
/// fn main() {
|
||||
-/// let tmp_dir = TempDir::new("test_fifo").unwrap();
|
||||
+/// let tmp_dir = TempDir::new().unwrap();
|
||||
/// let fifo_path = tmp_dir.path().join("foo.pipe");
|
||||
///
|
||||
/// // create new fifo and give read, write and execute rights to the owner
|
||||
--
|
||||
2.17.0
|
||||
|
@ -1,8 +1,14 @@
|
||||
--- nix-0.10.0/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||
+++ nix-0.10.0/Cargo.toml 2018-03-08T21:00:01.679343+01:00
|
||||
@@ -62,5 +62,3 @@
|
||||
+++ nix-0.10.0/Cargo.toml 2018-05-11T08:54:48.559521+02:00
|
||||
@@ -57,10 +57,5 @@
|
||||
[dev-dependencies.rand]
|
||||
version = "0.4"
|
||||
|
||||
-[dev-dependencies.tempdir]
|
||||
-version = "0.3"
|
||||
-
|
||||
[dev-dependencies.tempfile]
|
||||
version = "2"
|
||||
-version = "2"
|
||||
-[target."cfg(target_os = \"dragonfly\")".build-dependencies.gcc]
|
||||
-version = "0.3"
|
||||
+version = "3"
|
||||
|
Loading…
Reference in new issue