Update to 0.10.0

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 7 years ago
parent 3cbdac4f74
commit 6cbbfb4746
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -1 +1,2 @@
/nix-0.9.0.crate
/nix-0.10.0.crate

@ -1,45 +0,0 @@
From 453be9e9e7b2731fa8a5c9605104839dcd8285b7 Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
Date: Mon, 8 Jan 2018 00:13:59 +0100
Subject: [PATCH] make statfs/statvfs to be available wherever they are
available
libc reads sys/statvfs.h on all OS except Windows which nix doesn't care
about.
Closes: https://github.com/nix-rust/nix/issues/831
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
---
src/sys/mod.rs | 15 ++-------------
1 file changed, 2 insertions(+), 13 deletions(-)
diff --git a/src/sys/mod.rs b/src/sys/mod.rs
index 9636f93..9c12ede 100644
--- a/src/sys/mod.rs
+++ b/src/sys/mod.rs
@@ -62,20 +62,9 @@ pub mod select;
)]
pub mod quota;
-
-#[cfg(all(target_os = "linux",
- any(target_arch = "x86",
- target_arch = "x86_64",
- target_arch = "arm")),
- )]
+#[cfg(any(target_os = "android", target_os = "linux", target_os = "macos"))]
pub mod statfs;
-
-#[cfg(all(any(target_os = "linux",
- target_os = "macos"),
- any(target_arch = "x86",
- target_arch = "x86_64",
- target_arch = "arm")),
- )]
pub mod statvfs;
+
pub mod pthread;
--
2.15.1

@ -0,0 +1,8 @@
--- nix-0.10.0/Cargo.toml 1970-01-01T01:00:00+01:00
+++ nix-0.10.0/Cargo.toml 2018-03-08T21:00:01.679343+01:00
@@ -62,5 +62,3 @@
[dev-dependencies.tempfile]
version = "2"
-[target."cfg(target_os = \"dragonfly\")".build-dependencies.gcc]
-version = "0.3"

@ -1,17 +0,0 @@
--- nix-0.9.0/Cargo.toml 2017-07-24T05:08:20+02:00
+++ nix-0.9.0/Cargo.toml 2018-01-01T12:25:38.311243+01:00
@@ -21,11 +21,11 @@
void = "1.0.2"
[dev-dependencies]
-lazy_static = "0.2"
-rand = "0.3.8"
+lazy_static = "1"
+rand = "0.4"
tempdir = "0.3"
tempfile = "2"
-nix-test = { path = "nix-test", version = "0.0.1" }
+nix-test = { version = "0.0.1" }
[[test]]
name = "test"

@ -1,38 +1,33 @@
# Generated by rust2rpm
# * nix-test is nightly
%bcond_with check
%bcond_without check
%global debug_package %{nil}
%global crate nix
Name: rust-%{crate}
Version: 0.9.0
Release: 5%{?dist}
Version: 0.10.0
Release: 1%{?dist}
Summary: Rust friendly bindings to *nix APIs
License: MIT
URL: https://crates.io/crates/nix
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * No paths
# * Bump lazy_static to 1, https://github.com/nix-rust/nix/commit/dcd190a93cda47c525c6c51cc0159699333310fd
# * Bump rand to 0.4, https://github.com/nix-rust/nix/pull/822
Patch0: nix-0.9.0-fix-metadata.diff
# https://github.com/nix-rust/nix/pull/832
Patch1: 0001-make-statfs-statvfs-to-be-available-wherever-they-ar.patch
# * No dragonfly
Patch0: nix-0.10.0-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
# [dependencies]
BuildRequires: (crate(bitflags) >= 0.9.0 with crate(bitflags) < 0.10.0)
BuildRequires: (crate(bitflags) >= 1.0.0 with crate(bitflags) < 2.0.0)
BuildRequires: (crate(bytes) >= 0.4.5 with crate(bytes) < 0.5.0)
BuildRequires: (crate(cfg-if) >= 0.1.0 with crate(cfg-if) < 0.2.0)
BuildRequires: (crate(libc) >= 0.2.25 with crate(libc) < 0.3.0)
BuildRequires: (crate(libc) >= 0.2.36 with crate(libc) < 0.3.0)
BuildRequires: (crate(void) >= 1.0.2 with crate(void) < 2.0.0)
%if %{with check}
# [dev-dependencies]
BuildRequires: (crate(lazy_static) >= 1.0.0 with crate(lazy_static) < 2.0.0)
BuildRequires: (crate(nix-test) >= 0.0.1 with crate(nix-test) < 0.0.2)
BuildRequires: (crate(rand) >= 0.4.0 with crate(rand) < 0.5.0)
BuildRequires: (crate(tempdir) >= 0.3.0 with crate(tempdir) < 0.4.0)
BuildRequires: (crate(tempfile) >= 2.0.0 with crate(tempfile) < 3.0.0)
@ -63,16 +58,20 @@ which use %{crate} from crates.io.
%if %{with check}
%check
%cargo_test
# Testing parts are not distributed
%cargo_test --doc
%endif
%files devel
%license LICENSE
%doc CHANGELOG.md CONTRIBUTING.md CONVENTIONS.md README.md
%{cargo_registry}/%{crate}-%{version}/
%exclude %{cargo_registry}/%{crate}-%{version}/{Cross.toml,RELEASE_PROCEDURE.md,bors.toml}
%exclude %{cargo_registry}/%{crate}-%{version}/{Cross.toml,RELEASE_PROCEDURE.md,bors.toml,ci}
%changelog
* Thu Mar 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.10.0-1
- Update to 0.10.0
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.0-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

@ -1 +1 @@
SHA512 (nix-0.9.0.crate) = e9a2ef99c63cfa8d818ca5c41d8cb1472494fac60f86bda0c7646c5835a2c1ee92c10840c8c8da28044215bfc06b97881f57f602e8da5a55daad146b8bc10988
SHA512 (nix-0.10.0.crate) = 335bb939af0132511798e6c8cd259e82b6c5570a51b2dffab8c7c1c1ef13f473ead04bb5d99ad2aa383ea3529d6ec526a1c5dd0adf501d37406cbf3113b453df

Loading…
Cancel
Save