Initial import (mio 0.7 compat package)

epel9
Fabio Valentini 3 years ago
parent 563fcd8d71
commit e3fe2e7034
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

4
.gitignore vendored

@ -0,0 +1,4 @@
/results_*/
/*.src.rpm
/mio-0.7.14.crate

@ -1,3 +0,0 @@
# rust-mio0.7
The rust-mio0.7 package

@ -0,0 +1,15 @@
--- mio-0.7.14/Cargo.toml 1970-01-01T00:00:01+00:00
+++ mio-0.7.14/Cargo.toml 2022-02-03T14:09:14.295134+00:00
@@ -60,12 +60,3 @@
uds = ["net"]
[target."cfg(unix)".dependencies.libc]
version = "0.2.86"
-[target."cfg(windows)".dependencies.miow]
-version = "0.3.6"
-
-[target."cfg(windows)".dependencies.ntapi]
-version = "0.3"
-
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3"
-features = ["winsock2", "mswsock", "mstcpip"]

@ -0,0 +1,182 @@
# Generated by rust2rpm 20
%bcond_without check
%global debug_package %{nil}
%global crate mio
Name: rust-%{crate}0.7
Version: 0.7.14
Release: %autorelease
Summary: Lightweight non-blocking IO
# Upstream license specification: MIT
License: MIT
URL: https://crates.io/crates/mio
Source: %{crates_source}
# Initial patched metadata
# * drop windows-specific dependencies
Patch0: mio-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
%global _description %{expand:
Lightweight non-blocking IO.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE
%doc CHANGELOG.md README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+extra-docs-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+extra-docs-devel %{_description}
This package contains library source intended for building other packages which
use the "extra-docs" feature of the "%{crate}" crate.
%files -n %{name}+extra-docs-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+net-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+net-devel %{_description}
This package contains library source intended for building other packages which
use the "net" feature of the "%{crate}" crate.
%files -n %{name}+net-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+os-ext-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+os-ext-devel %{_description}
This package contains library source intended for building other packages which
use the "os-ext" feature of the "%{crate}" crate.
%files -n %{name}+os-ext-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+os-poll-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+os-poll-devel %{_description}
This package contains library source intended for building other packages which
use the "os-poll" feature of the "%{crate}" crate.
%files -n %{name}+os-poll-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+os-util-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+os-util-devel %{_description}
This package contains library source intended for building other packages which
use the "os-util" feature of the "%{crate}" crate.
%files -n %{name}+os-util-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+pipe-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+pipe-devel %{_description}
This package contains library source intended for building other packages which
use the "pipe" feature of the "%{crate}" crate.
%files -n %{name}+pipe-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+tcp-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tcp-devel %{_description}
This package contains library source intended for building other packages which
use the "tcp" feature of the "%{crate}" crate.
%files -n %{name}+tcp-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+udp-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+udp-devel %{_description}
This package contains library source intended for building other packages which
use the "udp" feature of the "%{crate}" crate.
%files -n %{name}+udp-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+uds-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+uds-devel %{_description}
This package contains library source intended for building other packages which
use the "uds" feature of the "%{crate}" crate.
%files -n %{name}+uds-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires -a
%build
%cargo_build -a
%install
%cargo_install -a
%if %{with check}
%check
%cargo_test -a
%endif
%changelog
%autochangelog

@ -0,0 +1 @@
SHA512 (mio-0.7.14.crate) = 2349691ea87a086f9bd8df5738705e9d7b59399089948f810b6a7124beffd44dee348703c89b4b1af8d84821dcb932960dc4bd9ec9543558f59a40c4806fbfd9
Loading…
Cancel
Save