import rust-mio-1.0.3-1.el10

i10ce changed/i10ce/rust-mio-1.0.3-1.el10
MSVSphere Packaging Team 2 months ago
commit 7fb7f380b5
Signed by: sys_gitsync
GPG Key ID: B2B0B9F29E528FE8

1
.gitignore vendored

@ -0,0 +1 @@
SOURCES/mio-1.0.3.crate

@ -0,0 +1 @@
1c9a8f7b2a503eec64a99975111bbaa6376dd042 SOURCES/mio-1.0.3.crate

@ -0,0 +1,43 @@
--- mio-1.0.3/Cargo.toml 1970-01-01T00:00:01+00:00
+++ mio-1.0.3/Cargo.toml 2024-12-01T20:27:28.713069+00:00
@@ -119,35 +119,11 @@
net = []
os-ext = [
"os-poll",
- "windows-sys/Win32_System_Pipes",
- "windows-sys/Win32_Security",
]
os-poll = []
-[target.'cfg(target_os = "hermit")'.dependencies.libc]
-version = "0.2.159"
-
-[target.'cfg(target_os = "wasi")'.dependencies.libc]
-version = "0.2.159"
-
-[target.'cfg(target_os = "wasi")'.dependencies.wasi]
-version = "0.11.0"
-
[target."cfg(unix)".dependencies.libc]
version = "0.2.159"
-
-[target."cfg(windows)".dependencies.windows-sys]
-version = "0.52"
-features = [
- "Wdk_Foundation",
- "Wdk_Storage_FileSystem",
- "Wdk_System_IO",
- "Win32_Foundation",
- "Win32_Networking_WinSock",
- "Win32_Storage_FileSystem",
- "Win32_System_IO",
- "Win32_System_WindowsProgramming",
-]
[lints.rust.unexpected_cfgs]
level = "warn"
@@ -156,3 +132,4 @@
"cfg(mio_unsupported_force_poll_poll)",
"cfg(mio_unsupported_force_waker_pipe)",
]
+

@ -0,0 +1,3 @@
[features]
enable-all = true

@ -0,0 +1,295 @@
## START: Set by rpmautospec
## (rpmautospec version 0.7.3)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 1;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 27
%bcond check 1
%global debug_package %{nil}
%global crate mio
Name: rust-mio
Version: 1.0.3
Release: %autorelease
Summary: Lightweight non-blocking I/O
License: MIT
URL: https://crates.io/crates/mio
Source: %{crates_source}
# Automatically generated patch to strip dependencies and normalize metadata
Patch: mio-fix-metadata-auto.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Lightweight non-blocking I/O.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+log-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+log-devel %{_description}
This package contains library source intended for building other packages which
use the "log" feature of the "%{crate}" crate.
%files -n %{name}+log-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+net-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+net-devel %{_description}
This package contains library source intended for building other packages which
use the "net" feature of the "%{crate}" crate.
%files -n %{name}+net-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+os-ext-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+os-ext-devel %{_description}
This package contains library source intended for building other packages which
use the "os-ext" feature of the "%{crate}" crate.
%files -n %{name}+os-ext-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+os-poll-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+os-poll-devel %{_description}
This package contains library source intended for building other packages which
use the "os-poll" feature of the "%{crate}" crate.
%files -n %{name}+os-poll-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires -a
%build
%cargo_build -a
%install
%cargo_install -a
%if %{with check}
%check
%cargo_test -a
%endif
%changelog
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 1.0.3-1
- Rebuilt for MSVSphere 10
## START: Generated by rpmautospec
* Sun Dec 01 2024 Fabio Valentini <decathorpe@gmail.com> - 1.0.3-1
- Update to version 1.0.3; Fixes RHBZ#2329526
* Tue Sep 17 2024 Fabio Valentini <decathorpe@gmail.com> - 1.0.2-1
- Update to version 1.0.2; Fixes RHBZ#2304079
* Sun Jul 28 2024 Fabio Valentini <decathorpe@gmail.com> - 1.0.1-1
- Update to version 1.0.1; Fixes RHBZ#2292381
* Sat Jul 20 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.11-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
* Fri Mar 08 2024 Fabio Valentini <decathorpe@gmail.com> - 0.8.11-1
- Update to version 0.8.11; Fixes RHBZ#2267369
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.10-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Thu Jan 11 2024 Fabio Valentini <decathorpe@gmail.com> - 0.8.10-1
- Update to version 0.8.10; Fixes RHBZ#2253192
* Wed Oct 25 2023 Fabio Valentini <decathorpe@gmail.com> - 0.8.9-1
- Update to version 0.8.9; Fixes RHBZ#2245636
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.8-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Sun Jun 04 2023 Fabio Valentini <decathorpe@gmail.com> - 0.8.8-1
- Update to version 0.8.8; Fixes RHBZ#2211201
* Sun May 28 2023 Fabio Valentini <decathorpe@gmail.com> - 0.8.7-1
- Update to version 0.8.7; Fixes RHBZ#2210551
* Sun Feb 19 2023 Fabio Valentini <decathorpe@gmail.com> - 0.8.6-1
- Update to version 0.8.6; Fixes RHBZ#2169701
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.5-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Sat Dec 10 2022 Fabio Valentini <decathorpe@gmail.com> - 0.8.5-1
- Update to version 0.8.5; Fixes RHBZ#2137380
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Fri Jul 15 2022 Fabio Valentini <decathorpe@gmail.com> - 0.8.4-1
- Update to version 0.8.4; Fixes RHBZ#2098462
* Wed May 11 2022 Fabio Valentini <decathorpe@gmail.com> - 0.8.3-1
- Update to version 0.8.3; Fixes RHBZ#2082946
* Tue Mar 29 2022 Fabio Valentini <decathorpe@gmail.com> - 0.8.2-1
- Update to version 0.8.2; Fixes RHBZ#2065428
* Sat Mar 12 2022 Fabio Valentini <decathorpe@gmail.com> - 0.8.1-1
- Update to version 0.8.1; Fixes RHBZ#2063212
* Thu Feb 03 2022 Fabio Valentini <decathorpe@gmail.com> - 0.8.0-1
- Update to version 0.8.0; Fixes RHBZ#2022964
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.14-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Fri Nov 05 2021 Fabio Valentini <decathorpe@gmail.com> - 0.7.14-1
- Update to version 0.7.14; Fixes RHBZ#2014779
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.13-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Sat Jun 19 2021 Fabio Valentini <decathorpe@gmail.com> - 0.7.13-1
- Update to version 0.7.13.
- Fixes RHBZ#1971183
* Tue Mar 23 2021 Fabio Valentini <decathorpe@gmail.com> - 0.7.11-1
- Update to version 0.7.11.
- Fixes RHBZ#1939250
* Tue Feb 23 2021 Fabio Valentini <decathorpe@gmail.com> - 0.7.9-1
- Update to version 0.7.9.
- Fixes RHBZ#1929906
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.7-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Thu Dec 31 2020 Fabio Valentini <decathorpe@gmail.com> - 0.7.7-1
- Update to version 0.7.7.
- Fixes RHBZ#1911692
* Thu Nov 19 2020 Fabio Valentini <decathorpe@gmail.com> - 0.7.6-1
- Update to version 0.7.6.
- Fixes RHBZ#1898162
* Thu Nov 05 2020 Fabio Valentini <decathorpe@gmail.com> - 0.7.5-1
- Update to version 0.7.5.
- Fixes RHBZ#1883627
* Wed Oct 07 2020 Fabio Valentini <decathorpe@gmail.com> - 0.7.2-1
- Update to version 0.7.2.
* Thu Oct 01 2020 Fabio Valentini <decathorpe@gmail.com> - 0.7.1-1
- Update to version 0.7.1.
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Wed Apr 29 01:28:15 CEST 2020 Marc-André Lureau <marcandre.lureau@redhat.com> - 0.7.0-1
- Update to 0.7.0
* Wed Feb 19 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.6.21-3
- Fix FTBFS
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.21-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Tue Dec 10 2019 Josh Stone <jistone@redhat.com> - 0.6.21-1
- Update to 0.6.21
* Fri Nov 22 2019 Josh Stone <jistone@redhat.com> - 0.6.20-1
- Update to 0.6.20
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.19-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Fri Jun 21 21:27:15 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.19-2
- Regenerate
* Sat Jun 01 2019 Josh Stone <jistone@redhat.com> - 0.6.19-1
- Update to 0.6.19
* Sun Feb 10 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.16-3
- Adapt to new packaging
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.16-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Sat Sep 08 2018 Josh Stone <jistone@redhat.com> - 0.6.16-1
- Update to 0.6.16
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.15-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Wed Jul 11 2018 Josh Stone <jistone@redhat.com> - 0.6.15-1
- Update to 0.6.15
* Fri Jun 15 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.14-2
- Bump lazycell to 1
* Fri Mar 09 2018 Josh Stone <jistone@redhat.com> - 0.6.14-1
- Update to 0.6.14
* Wed Feb 07 2018 Josh Stone <jistone@redhat.com> - 0.6.13-1
- Update to 0.6.13
* Wed Jan 10 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.12-1
- Update to 0.6.12
* Fri Dec 01 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.11-1
- Update to 0.6.11
* Fri Jun 16 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.9-1
- Initial package
## END: Generated by rpmautospec
Loading…
Cancel
Save