Update to 0.7.0

epel9
Marc-André Lureau 5 years ago
parent 7b9dbe035a
commit 5c735f9c85

1
.gitignore vendored

@ -6,3 +6,4 @@
/mio-0.6.19.crate
/mio-0.6.20.crate
/mio-0.6.21.crate
/mio-0.7.0.crate

@ -1,21 +1,33 @@
--- mio-0.6.20/Cargo.toml 1970-01-01T00:00:00+00:00
+++ mio-0.6.20/Cargo.toml 2019-11-22T19:34:26.604578+00:00
@@ -54,18 +54,5 @@
[features]
default = ["with-deprecated"]
with-deprecated = []
-[target."cfg(target_os = \"fuchsia\")".dependencies.fuchsia-zircon]
-version = "0.3.2"
-
-[target."cfg(target_os = \"fuchsia\")".dependencies.fuchsia-zircon-sys]
-version = "0.3.2"
--- mio-0.7.0/Cargo.toml 2020-03-02T18:00:05+00:00
+++ mio-0.7.0/Cargo.toml 2020-04-30T17:43:14.500010+00:00
@@ -15,7 +15,13 @@
name = "mio"
version = "0.7.0"
authors = ["Carl Lerche <me@carllerche.com>"]
-exclude = [".gitignore", ".travis.yml"]
+exclude = [
+ ".cirrus.yml",
+ ".gitignore",
+ ".travis.yml",
+ "azure-pipelines.yml",
+ "ci/"
+]
description = "Lightweight non-blocking IO"
homepage = "https://github.com/tokio-rs/mio"
documentation = "https://docs.rs/mio/0.7.0"
@@ -54,15 +60,3 @@
uds = []
[target."cfg(unix)".dependencies.libc]
version = "0.2.42"
-[target."cfg(windows)".dependencies.kernel32-sys]
-version = "0.2"
version = "0.2.62"
-[target."cfg(windows)".dependencies.lazy_static]
-version = "1.4.0"
-
-[target."cfg(windows)".dependencies.miow]
-version = "0.2.1"
-version = "0.3.3"
-
-[target."cfg(windows)".dependencies.ntapi]
-version = "0.3"
-
-[target."cfg(windows)".dependencies.winapi]
-version = "0.2.6"
-version = "0.3"
-features = ["winsock2", "mswsock"]

@ -1,12 +1,12 @@
# Generated by rust2rpm 11
# Generated by rust2rpm 13
%bcond_without check
%global debug_package %{nil}
%global crate mio
Name: rust-%{crate}
Version: 0.6.21
Release: 3%{?dist}
Version: 0.7.0
Release: 1%{?dist}
Summary: Lightweight non-blocking IO
# Upstream license specification: MIT
@ -14,7 +14,7 @@ License: MIT
URL: https://crates.io/crates/mio
Source: %{crates_source}
# Initial patched metadata
# * No windows or fuchsia
# no cfg(windows) deps, exclude more CI files
Patch0: mio-fix-metadata.diff
ExclusiveArch: %{rust_arches}
@ -41,8 +41,7 @@ which use "%{crate}" crate.
%files devel
%license LICENSE
%doc README.md CHANGELOG.md
%{cargo_registry}/%{crate}-%{version}/
%exclude %{cargo_registry}/%{crate}-%{version}/{azure-pipelines.yml,.cirrus.yml,ci}
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -54,40 +53,103 @@ This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+with-deprecated-devel
%package -n %{name}+extra-docs-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+with-deprecated-devel %{_description}
%description -n %{name}+extra-docs-devel %{_description}
This package contains library source intended for building other packages
which use "with-deprecated" feature of "%{crate}" crate.
which use "extra-docs" feature of "%{crate}" crate.
%files -n %{name}+with-deprecated-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%files -n %{name}+extra-docs-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+os-poll-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+os-poll-devel %{_description}
This package contains library source intended for building other packages
which use "os-poll" feature of "%{crate}" crate.
%files -n %{name}+os-poll-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+os-util-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+os-util-devel %{_description}
This package contains library source intended for building other packages
which use "os-util" feature of "%{crate}" crate.
%files -n %{name}+os-util-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+tcp-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tcp-devel %{_description}
This package contains library source intended for building other packages
which use "tcp" feature of "%{crate}" crate.
%files -n %{name}+tcp-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+udp-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+udp-devel %{_description}
This package contains library source intended for building other packages
which use "udp" feature of "%{crate}" crate.
%files -n %{name}+udp-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+uds-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+uds-devel %{_description}
This package contains library source intended for building other packages
which use "uds" feature of "%{crate}" crate.
%files -n %{name}+uds-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%cargo_generate_buildrequires -a
%build
%cargo_build
%cargo_build -a
%install
%cargo_install
%cargo_install -a
%if %{with check}
%check
# Tests below depend on having networking present
%cargo_test -- -- --skip poll::Poll --skip poll::Poll::deregister --skip poll::Poll::register --skip poll::Poll::reregister --skip sys::unix::ready::UnixReady --skip test_multicast::test_multicast
export RUST_BACKTRACE=1
%cargo_test -a
%endif
%changelog
* Wed Apr 29 01:28:15 CEST 2020 Marc-André Lureau <marcandre.lureau@redhat.com> - 0.7.0-1
- Update to 0.7.0
* Wed Feb 19 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.6.21-3
- Fix FTBFS

@ -1 +1 @@
SHA512 (mio-0.6.21.crate) = 2bc68f6ff424d3ae2ef67a6a1a708b4c42b05f616cad1b0061dce3157c6a46d0666173e65c6f8b7960051e21b526ab5acbdc835833b5496fda280719ad139c77
SHA512 (mio-0.7.0.crate) = c7e00a45906db97f7ba3b91114ad1fa3a120598b13bbe9dd822e786d5bebd8721b54843a57d04d13190d5873cdee99f55f9cf467c5c27c7d7b9ed1c6251a03cf

Loading…
Cancel
Save