Update to version 0.8.0; Fixes RHBZ#2022964

epel9
Fabio Valentini 3 years ago
parent 1a5efee27f
commit 388ed48d90
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -16,3 +16,4 @@
/mio-0.7.11.crate
/mio-0.7.13.crate
/mio-0.7.14.crate
/mio-0.8.0.crate

@ -1,7 +1,7 @@
--- mio-0.7.14/Cargo.toml 1970-01-01T00:00:01+00:00
+++ mio-0.7.14/Cargo.toml 2021-11-05T22:28:45.269699+00:00
@@ -60,12 +60,3 @@
uds = ["net"]
--- mio-0.8.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ mio-0.8.0/Cargo.toml 2022-02-03T14:10:08.584099+00:00
@@ -53,12 +53,3 @@
os-poll = []
[target."cfg(unix)".dependencies.libc]
version = "0.2.86"
-[target."cfg(windows)".dependencies.miow]
@ -12,4 +12,4 @@
-
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3"
-features = ["winsock2", "mswsock", "mstcpip"]
-features = ["winsock2", "mswsock"]

@ -1,11 +1,11 @@
# Generated by rust2rpm 18
# Generated by rust2rpm 20
%bcond_without check
%global debug_package %{nil}
%global crate mio
Name: rust-%{crate}
Version: 0.7.14
Version: 0.8.0
Release: %autorelease
Summary: Lightweight non-blocking IO
@ -18,9 +18,6 @@ Source: %{crates_source}
Patch0: mio-fix-metadata.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
@ -35,12 +32,12 @@ BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE
%doc README.md CHANGELOG.md
%doc CHANGELOG.md README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%package -n %{name}+default-devel
@ -49,32 +46,20 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+extra-docs-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+extra-docs-devel %{_description}
This package contains library source intended for building other packages
which use "extra-docs" feature of "%{crate}" crate.
%files -n %{name}+extra-docs-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+net-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+net-devel %{_description}
This package contains library source intended for building other packages
which use "net" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "net" feature of the "%{crate}" crate.
%files -n %{name}+net-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -85,8 +70,8 @@ BuildArch: noarch
%description -n %{name}+os-ext-devel %{_description}
This package contains library source intended for building other packages
which use "os-ext" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "os-ext" feature of the "%{crate}" crate.
%files -n %{name}+os-ext-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -97,72 +82,12 @@ BuildArch: noarch
%description -n %{name}+os-poll-devel %{_description}
This package contains library source intended for building other packages
which use "os-poll" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "os-poll" feature of the "%{crate}" crate.
%files -n %{name}+os-poll-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+os-util-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+os-util-devel %{_description}
This package contains library source intended for building other packages
which use "os-util" feature of "%{crate}" crate.
%files -n %{name}+os-util-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+pipe-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+pipe-devel %{_description}
This package contains library source intended for building other packages
which use "pipe" feature of "%{crate}" crate.
%files -n %{name}+pipe-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+tcp-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tcp-devel %{_description}
This package contains library source intended for building other packages
which use "tcp" feature of "%{crate}" crate.
%files -n %{name}+tcp-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+udp-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+udp-devel %{_description}
This package contains library source intended for building other packages
which use "udp" feature of "%{crate}" crate.
%files -n %{name}+udp-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+uds-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+uds-devel %{_description}
This package contains library source intended for building other packages
which use "uds" feature of "%{crate}" crate.
%files -n %{name}+uds-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

@ -1 +1 @@
SHA512 (mio-0.7.14.crate) = 2349691ea87a086f9bd8df5738705e9d7b59399089948f810b6a7124beffd44dee348703c89b4b1af8d84821dcb932960dc4bd9ec9543558f59a40c4806fbfd9
SHA512 (mio-0.8.0.crate) = b7db8f400c46937302a091a90ef05b501aaaf8cbd9b5d8a4415e140e5ad54fe745ac3248b49a6ab42399d145c01fbbdf0a69defc379caaa67f64e8b7cf160b07

Loading…
Cancel
Save